Problems trying to get "A Helvetica Neue [adobe]" in system

Discussion in 'Design and Graphics' started by kkamin, Apr 2, 2009.

  1. kkamin macrumors member

    Joined:
    Mar 24, 2009
    #1
    I'm operating off of Mac 10.5.6.

    I've tried loading the Font Suitcase file for "A Helvetica Neue" with Font Book and Linotype Font Explorer X but it will not take it.

    Apparently "Helvetica Neue" is a system font, so I thought that might be a problem. I went through the process of digging it out of the "protected fonts" folder, deep in the recesses of the mac, and after getting rid of any trace of it. It still would not accept the Font Suitcase.

    Any ideas?
     
  2. lurcher macrumors regular

    lurcher

    Joined:
    Mar 4, 2004
    Location:
    England
    #2
    Hi, have you tried a restart since doing this?
     
  3. jeremy h macrumors 6502

    Joined:
    Jul 9, 2008
    Location:
    UK
    #3
    Ah, Helvetica and OSX 10.5... What Fun!

    Not sure exactly what your problem is but perhaps it's automatically being re-installed before you load your version? The naming needs to be right...

    I've cut and pasted this (my emphasis):

    Myth 3: You cannot delete the system’s Helvetica in Leopard.
    Actually, you can! Just open this folder:

    System/Library/Frameworks/ApplicationServices.framework/
    Versions/A/Frameworks/ATS.framework/Versions/A/Resources/ProtectedFonts/

    This is the folder Leopard uses to reinstall the fonts. If you delete them here and in the system folder (system/library/fonts), the fonts will not be reinstalled. Warning: Mac OS X needs Helvetica! If you delete the Helvetica dfonts, make sure to install your own Helvetica. It needs to have the name “Helvetica” as font family name. No other name (like “Helvetica LT” or “Helvetica Neue”) will be a proper replacement.


    From here

    Make sure you're careful about the helvetica naming bit though - and I'd keep a copy of the dfont somewhere just in case...
     

Share This Page