Problems typing in japanese characters on a MacBook!!

Discussion in 'Mac Basics and Help' started by jhb104756, Mar 11, 2010.

  1. jhb104756 macrumors newbie

    Mar 11, 2010
    More specifically when typing one character...
    When I type in Hiragana - わたし (watashi) it should convert to this character 私 however... it doesnt. the first character it converts to is this... わ足し!!

    Watashi is one of the most common characters. It means "I" and I need to use it!
    I used to be able to type it and only recently have noticed I can not do this.

    Does anybody have a similar problem? heard of or seen this before? know how to correct the problem? All your help would be good?

    My MacBook was purchased in Japan and has a Japanese keyboard!  
  2. jackerin macrumors 6502a

    Jun 29, 2008
    That sounds strange indeed. If 私 still shows up in the list when hitting the space-bar try typing it a few times and choosing it every time and see if it becomes the first choice.
  3. angelwatt Moderator emeritus


    Aug 16, 2005
    I haven't had issues with this either. Just make sure to hit the space bar at the end, and don't hit enter during the typing starting at wa. Does it matter what program you're typing in?
  4. jhb104756 thread starter macrumors newbie

    Mar 11, 2010
    Very strange

    Thanks guys...
    Thats the thing...

    when I type わたし and press space-bar the "私" character doesnt even show up in the list, however it used to and it used to be first.

    It doesnt matter whether I am using the internet... this site, facebook, google etc, Microsoft software ie Word & Excel, Apple software ie Aperture, Pages, & Keynote etc....

    If anyone has any ideas or possible avenues to chase down that would be good... dont really want to pay apple $60 AUD for them to 'troubleshoot' and not guarantee a solution!!!
  5. zorahk macrumors 6502

    Jul 18, 2008
    North Korea
    I have had this kind of problem. At the bottom there should be "others for watashi" or something, click on that and then find it, once you select it it will become the most common one used.
  6. angelwatt Moderator emeritus


    Aug 16, 2005
    I wonder if the dictionary has become corrupt in some manner. I did a search and found this article. It doesn't describe your problem, but could be of help.

    You can also take a look at the Kotoeri preferences, which is accessible from the menu bar item (keyboard menu) where it shows what typing mode you're in. Perhaps there is a setting in there that got changed that's causing this.
  7. jhb104756 thread starter macrumors newbie

    Mar 11, 2010
    No Progress...

    Zorahk... not that because the [ 私 ] is no where to be found anywhere in the list even in the 'others' drop down

    The article was interesting, however i tried it but didnt work... its really bugging me cos it seems to be some setting thing or software.. not hardware...

    Keep thinking guys
  8. chill. macrumors 6502

    Sep 1, 2008
    click on language pack icon

    edit dictionary

    add word
  9. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Found The Solution!

    Interesting. In the process of typing up suggestions for this, I figured out what the problem is, then took another 20 minutes to find the fix. I also, while looking, stumbled across two incredibly useful features that I did not know were even there, which is awesome. Seriously, AWESOME.

    Here's what's going wrong: If you type わたし once and then bring up the suggested predictions list for it, but instead of selecting the correct character select わ足し instead, it remembers that as your preferred choice. You probably accidentally hit space an extra time without realizing it or something.

    The PROBLEM is that once you've done that, the suggested prediction that pops up with わたし will ALWAYS assume you just want options for the first character, and will NEVER suggest all three. I'm nearly certain this is a bug, maybe quite recent (I'm using 10.6.2, and I'm sure it worked properly in 10.5.something, not to mention if it had been around for a while surely people would have complained and/or fixed it).

    The prediction list that is causing the problem here is stored in ~/Library/Preferences/

    That's a folder with a number of files in it, but I couldn't easily figure out which was the problem or how to edit them. If, however, you trash that whole folder, log out, and then log back in (or reboot), your preferred predictions will be forgotten and you're back in business. You'll also lose all the correct ones, but that's probably not a huge problem.

    Perhaps someone else knows how to edit the dictionaries manually to remove the bad association, though really this issue should never happen in the first place, because the OS should be offering predictions for the whole word if the first-character suggestions aren't sufficient.

    Also, it seems like the Kotoeri preferences aren't working; the check box for "Show predicted candidates" doesn't seem to do anything on my system, but if I understand what it's supposed to do correctly it should stop Kotoeri from suggesting any previously-used selections at all. Maybe I just don't get what it's supposed to do.

    I'd be really interested if people could try this and see if it creates the same catch-22 for them. Particularly curious if it's new in 10.6.something, or if it has existed for longer. A little more data to submit a bug report to Apple would probably be useful.

    Now for my two peripheral discoveries: First, I found out that the OS already has a huge Japanese-English dictionary, plus a pure-Japanese regular dictionary, built-in. You can turn them on via the preferences of Had no idea that was in there, but SO useful.

    Second, I thought that Apple had dropped the preference that allowed you to switch between a per-document input method and a systemwide input method in 10.5. I preferred systemwide, so this didn't bother me, but my wife liked the other, as did some people here asking where it went a while back, and I thought there was no way to switch anymore. Turns out that it's there, it's just in a different place--it now appears to the right of the Input Sources list. I could swear that wasn't there in 10.5, so maybe they put it back in 10.6.

    Either way, sweet for people who prefer the old style method.

    Wasted a bunch of time digging myself out of the hole I created trying to help, but I'm happy anyway!
  10. jackerin macrumors 6502a

    Jun 29, 2008
    I sort of suspected it could be a preference file myself, but couldn't be bothered to find where they were stored.. :p

    Curiously, I don't even get わ足し as an option when typing わたし. Using 10.4.11 here.
  11. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Follow-up note, I just tried on my machine running 10.5.8 at work, and while you can get it to incorrectly auto-suggest わ足し, if you hit space again it will offer 私 like it's supposed to.

    Meaning this bug was introduced in 10.6. Maybe even 10.6.2--anybody running an earlier version?

    Also, I wasn't just stupid--the option to set the input mode by document instead of systemwide was gone in 10.5--they put it back in 10.6. Bet that alone is reason enough for some people to upgrade.
  12. dxintokyo macrumors newbie

    Aug 31, 2011
    Problems typing in japanese characters on my MacBook!!

    hi all,

    for some reason, some japanese words get converted into letters ;(

    when "shinjuku" is written in japanese kanji, it changes to "k" :(
    when "seikatsu" is written in japanese kanji, it changes to "u" ;(

    but other words like "shigoto" or "ryouhou" comes out in japanese like it's supposed to.

    i currently use a macbook version 10.6.6. i did a disk utility check and everything is fine.

    hope someone in this group can help!

    thanks and arigato!
  13. RMurphy macrumors newbie

    Dec 17, 2011
    Same kotoeri problem

    Yes, I have the same kotoeri problems since getting my new iMac and Office 2011. Very frustrated. Tried going through the MS turn-on-japanese-language-features as suggested elsewhere on Macrumors but problem persisted after I closed doc and reopened it. Tried flipping first language choice in system prefs.

    Most of previous posts were from 2011, wondering if there is anything new (solutions) by this time!
  14. hc_mty macrumors newbie


    Sep 7, 2015
    Monterrey, Mx.

    I had the same problem and solve it successfully. This is what I did.

    Due I have configured my OSX to spanish, I make this animated gif to show you the path.

    I really hope you find it useful.

  15. tf9623 macrumors newbie

    Oct 23, 2015

    Muchas gracias!! Trabajo bueno.

Share This Page