Problems updating JB'd 4S

Discussion in 'Jailbreaks and iOS Hacks' started by hakr100, May 25, 2012.

  1. hakr100 macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
    #1
    I'm running 5.0.1 on my JB'd 4S and now that the 5.1.1 JB is out, I tried updating to 5.1.1. I did not "reset" the phone. The update failed OTA and while connected to itunes, the latter telling me my phone was not eligible for the update.

    I've backed up all my JB stuff.

    What should I do to update the phone to the latest 5.1.1?

    Thanks!
     
  2. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #2
    same problem here. I tried DFU mode as well, and my 4s will not update to 5.1.1. Now I'm stuck in recovery mode. Ideas anyone?
     
  3. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #3
    Download a fresh copy of iOS 5.1.1 and then DFU restore using iTunes.
     
  4. terraphantm macrumors 68040

    Joined:
    Jun 27, 2009
    Location:
    Pennsylvania
    #4
    Make sure hosts file isn't set to use cydia as the apple update server
     
  5. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #5
    tried that.. no luck
     
  6. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #6
    TinyUmbrella helped me get out of recovery mode.
     
  7. TheSlimOne macrumors regular

    Joined:
    Jun 19, 2010
    #7
    I am currently updating my itunes. I'll report back. I am having the same issue
     
  8. hakr100 thread starter macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
    #8
    Well, it bombed out on my iMac, so I booted into windows via VMware Fusion and did a restore via iTunes there. Damned weird.
     
  9. Trey1984 macrumors regular

    Joined:
    Mar 5, 2011
    #9
    keep kicking out of recover with tiny umbrella, the servers are slammed right now guys. It will work, be patient
     
  10. Netherscourge, May 25, 2012
    Last edited: May 25, 2012

    Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #10
    This fixed my problem.

    You go into the iTunes syshost file, open it with a text editor and delete the IP address for CYDIA at the very end.

    (I didn't even put Apple's IP in there - iTunes does it automatically if it doesn't see any other address)

    Save it, close out and then run the restore or upgrade. Should work then.

    I don't recall the exact directory of the file though - different OS's have different locations for it. And it was in a hidden file too - show make sure you show hidden files when looking for it.

    I think it's something like in here:

    C:\Windows\System32\ drivers\etc\hosts

    Depending on your Windows OS. (Not sure about Mac OS)


    EDIT: It'll look something liek this in a Text editor (Open with WordPad)

    A standard Windows hosts file should look something like this -



    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    127.0.0.1 localhost


    ---If you see an IP address at the bottom there with CYDIA or SAURIK in it, delete that whole line and re-save the file. Don't change anything else.
     
  11. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #11
    on a Mac (or other Linux flavors) its /etc/hosts

    TinyUmbrella does this for you. And I recommend it for those not comfy with editing system files.



     
  12. apollo1444 macrumors 65816

    Joined:
    Jul 22, 2011
    Location:
    mexico
    #12
    haven't you learn anything? JB iPhones SHOULD NOT UPDATE OTA
     

Share This Page