Problems Updating to 4.2

Discussion in 'iPad' started by ardesigns, Nov 27, 2010.

  1. ardesigns macrumors member

    Joined:
    Mar 20, 2008
    #1
    Hi. As everyone knows, iOS 4.2 for iPad came out the other day. I decided to restore and update mine. I clicked the restore button and, when asked, clicked "update and restore." iTunes downloaded iOS 4.2, and went to restore the iPad. Everything looked fine until the last maybe 2% of the progress bar (both in iTunes and on my iPad), where it just hung up. It sat there for about 5 hours, and I just unplugged it and turned it off. I tried another time, same problem. I tried once more, this time using iPad iOS 4.2 firmware that I downloaded from the internet, and I still had the same problem.

    Has anyone else had this problem? Does anyone know how I can get the iPad to update (+ restore) without it hanging up?

    Thanks!
     
  2. iTouch.lover22 macrumors regular

    Joined:
    Oct 30, 2009
    #2
    I did an OS upgrade but not a restore, and had the same problem as you. Downloaded the firmware update, everything went through smoothly, then iTunes told me the iPad would restart. So it would restart, start syncing, and the progress bar on the iPad would go to no less than 95% complete before simply stopping, and iTunes would freeze. I had to do nearly a dozen hard resets trying both plugged in to the computer and unplugged before finally getting the iPad to start again. Just try hard resets, don't know anything else you can do.
     
  3. ardesigns thread starter macrumors member

    Joined:
    Mar 20, 2008
    #3
    Well it's not that it won't restart, it's that it won't finish the restore/update itself. Now, whenever I click the home button (or anything else to turn it on) it says to connect to iTunes. When I do, iTunes says it has detected an iPad in recovery mode, and that I have to restore it. When I restore it, I get the same problem (it won't finish the restore/update), and then I unplug it and the cycle starts all over again.

    Please help!

    Thanks again.
     
  4. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #4
    I actually had this same problem at first. Thought I had totally bricked my iPad. I tried everything just like you until I had one last idea to reinstall iTunes 10.1. I just downloaded the iTunes setup file from Apple's site again and reinstalled iTunes 10.1 on my MacBook and everything installed fine after that with no hanging at the end. Try that and hopefully it works for you too. Good luck! :)
     
  5. ardesigns thread starter macrumors member

    Joined:
    Mar 20, 2008
    #5
    I reinstalled iTunes 10.1, and it worked!

    Thanks so much!
     
  6. Fuzzy.Dunlop macrumors regular

    Joined:
    Jan 12, 2010
    Location:
    London
    #6
    I've updated 2 iphones and a touch with no issues but with my sisters iPad is taking (so far 3hrs) to only get to 50% through the update (the iPad is currently backing up for the second time after the update)

    Is this normal for iPads to take so long to update (i'm on a mac but her windows laptop was taking even longer to get to 50%)
     

Share This Page