Problems upgrading iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fridgedesign, Jul 26, 2012.

  1. fridgedesign macrumors newbie

    Joined:
    Jun 25, 2010
    #1
    Hi

    I have an iphone 4 running 4.3.2 (8H7) with baseband 04.10.01 using a GEVEY sim tray.

    I want to upgrade to IOS 5.

    I have preserved my IOS 5.0.1 baseband using Redsn0w_mac_0.9.12b1. Put my phone into DFU mode and tried to update in iTunes.

    But I receive a 'The iPhone could not be restored. This device isn't eligible for the requested build'

    I have adapted my HOST file and tried using Tiny Umbrella yet still no luck.

    Does anyone else have any ideas???
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    You need to stitch your SHSH/APTicket to the custom firmware to upgrade to 5.01 as it is no longer signed by apple, if you don't have those than only option is to upgrade to 5.1.1 while preserving the baseband, which is what i would do.

    Tutorials on stitching can be found on iclarified.com
     
  3. dan4877 macrumors newbie

    Joined:
    Jul 23, 2012
    #3
    Lost files when I upgraded...

    I made the update on my iphone4 a couple months back. I did a file backup before upgrading and after the upgrade all of my music was gone, as well as my apps. It did however restore all my pictures and videos. I called Apple and they said the only way to get these files back is to go back to the original computer I had it synced to... which I no longer have. Anyone know how to get my files back?
     

Share This Page