Problems upgrading Macbook Ram...

Discussion in 'Mac Basics and Help' started by loztheguru, Aug 19, 2006.

  1. loztheguru macrumors member

    Aug 7, 2006
    My ram upgrade arrived today (3rd party), and im fairly competnet, built my own pc etc, so I didnt think itd be a problem. However, I cannot get the middle screw out!

    Of the 3 screws holding the metal plate in place, ive managed to get both end ones out, however I really cant seem to get the middle one out, it really is stuck. I dont want to try and force it, as the thread has already stripped a little, and I dont want to worsen the problem. The screwdriver im using worked fine with the other two, but this one wont budge.

    Anyone else had this problem or cna offer me some advice?

  2. furious macrumors 65816


    Aug 7, 2006
    i had the same problem. what i did was walked away they came back to it after about an hour. i had settled down by then and it came out easy
  3. scottm macrumors newbie

    Aug 14, 2006
    Jersey City, NJ
    I had the same problem with the middle screw. I'd been using a slightly off-size screwdriver (which worked fine without stripping the other two) but couldn't get the middle one to budge without risking stripping it. I went and bought the correct size phillips and it still wouldn't budge without about 5 minutes of trying. I was fairly sure I'd end up with a stripped screw, but it finally came out just fine.

    Putting the bracket back, I also had to hold the shielding in with another screwdriver to get the bracket to sit correctly. Fortunately the third party memory (G-Skill) worked fine and was detected straight away on the reboot.

Share This Page