Problems using a FW800>400 adapter to connect DV device to new MBP

Discussion in 'Digital Video' started by AVR2, Jul 7, 2009.

  1. AVR2 macrumors 6502

    Joined:
    Jan 16, 2006
    #1
    We're trying to connect a Sony J-30 VTR to a unibody MBP. The VTR has a standard 6-pin FW400 port on the back, we're using a FW800>400 adapter cable... and the MBP just will not see the VTR at all.

    Using an external FW800 HD, we've confirmed that the MBP's FW800 port and cable work. All of Apple's official documentation for FW800 says that with an adapter cable you get "seamless" support of legacy FW400 devices, but it just ain't happening.

    We've tried three different J-30s, all with no result. All of the VTRs work perfectly when connected to a FW400 port on an older MBP.

    Are there any hidden FW config options within OS X or FCP that we could try?
     
  2. hvfsl macrumors 68000

    hvfsl

    Joined:
    Jul 9, 2001
    Location:
    London, UK
    #2
    Well it just worked on mine, sounds like you ether have a dodgy port/cable/adapter.
     
  3. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #3
    So you've got a unibody MBP controlling a J-30 with no issues? What sort of cable are you using?

    It's an odd one because the MBP's FW800 port and the 800>400 cable work fine when connected to a FW hard drive, and yet three different J-30s refuse to work with it, although they all work normally with a 400>400 cable.
     
  4. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #4
    Have you tried shutting down both machines, plug the deck into the laptop, power up the deck, then power up the laptop? Sometimes FCP is finicky w/the boot order. Also, w/everything hooked up and running open the Apple menu, select About This Mac, More Info, and select Firewire under Hardware. If the computer sees the deck on the FW bus then it's a FCP problem. If the computer doesn't see the deck on the bus then it's a hardware problem.


    Lethal
     
  5. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #5
    Tried that, made no difference sadly :(

    However, we *did* find a solution!

    I suddenly thought "Hang on, FW devices can be daisy-chained", so just as an experiment, I connected the FW800>400 cable to an old FW400 hard drive we have lying around, and then used a 400>400 cable to connect the hard drive to the J-30.

    Bingo - the MBP can see both devices and is now happily controlling the VTR :cool: Although for some reason, the J-30 doesn't show up as part of the FW bus in "About This Mac", only the HD does.

    Presumably, then, J-30s need some kind of FW400 hub between them and a FW800 port. I wonder if that's down to the design of the FW card Sony uses in them?
     
  6. TheNightPhoenix macrumors 6502

    Joined:
    Dec 16, 2005
    #6
    I just managed to recreate your problem at work.
    We found a Belkin 800 to 400 cable caused issues with an Device, but a cheap 400 female to 800 male adaptor worked fine.
    In our case it seems to be a power issue, the device was bus powered and wouldn't switch on.
     

Share This Page