Problems using Bibtex from within TeXShop

Discussion in 'Mac Apps and Mac App Store' started by macbook123, Sep 3, 2011.

  1. macbook123 macrumors 68000

    Joined:
    Feb 11, 2006
    #1
    Hi, I'm having difficulties using bibtex from within texshop. I'm under OS X Lion. I know that the workflow is supposed to be latex-bibtex-latex-latex. For some reason I'm getting the error message

    "I found no \citation commands---while reading file publication.aux"

    I copied the whole directory including the .bib file to a Linux computer and it works beautifully there. Any thoughts on what I could be doing wrongly?
     
  2. blipmusic, Sep 3, 2011
    Last edited: Sep 5, 2011

    blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #2
    I tried looking around but found no obvious solution.

    Since you say it all works in Linux (the Linux output looks ok, right?), I assume you actually have \cite{your_reference_here} commands within your document (otherwise include some - or try \nocite{*} to include the whole bibliography list in your bib-file.).

    Only thing that made sense was that on Mac the aux-file the aux-file sometimes won't update. Perhaps try from scratch? I.e. make a new folder and include only your tex-file and your bib-file and see if that works out.

    Also, if you have any packages that alter your bibliography try to temporarily comment them out our or remove them from your preamble. Perhaps even update your latex installation and/or all packages in your current installation. If you use MacTex, it was recently updated. Try using the Tex Live Utility in the tex folder found in your applications folder.

    Heh, I usually recommend latex left and right but the problem is that when an error like this occurs, finding a solution can be difficult at best sometimes.
     
  3. Chris86 macrumors newbie

    Joined:
    Mar 16, 2012
    #3
    Another way

    I found this thread while googling my own problem and this answer was not useful to me.

    In case anyone else comes across this thread and, like me, doesn't know much about LaTeX or really care too much, here is how I fixed the problem:

    Make sure your LaTeX document is structured properly. Close those {}!

    I spent 30 mins crawling through technical answers, lines and lines of clever people saying clever things. Then I realised I had left a \section{} open. Closed it off and voila - problem solved.
     

Share This Page