Problems utomatically opening downloaded Word files

Discussion in 'iMac' started by joebaroque, Jun 13, 2008.

  1. joebaroque macrumors newbie

    Joined:
    Jun 13, 2008
    #1
    Hi - I've just started encountering a problem with my iMacs: If I download a Word document from an email (i.e. the file is an attachment) in SOME cases, the iMac will not automatically open the file in Word. It opens Word, and then a general, NEW document (Document 1), but not the file that was downloaded.

    I originally thought these were Word documents created elsewhere (of course) in Vista, but this is not always the case. Some may be, but others I have created on other macs or on my Powerbook G4 (running with upgraded Leopard).

    The same files that do not open automatically on the iMac (when downloaded from email) do so with no problems on the PowerBook.

    Any ideas how to correct this problem?
     
  2. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #2
    Try just downloading the attachment. Then find the file in Finder, right click and select "Get Info". In the "Open With" section, make sure Microsoft Word is selected, then click "Change All". See if that works
     
  3. joebaroque thread starter macrumors newbie

    Joined:
    Jun 13, 2008
    #3
    continued problems opening word docs

    Thanks for the suggestion.

    Unfortunately, I have already tried that, and it does not work.

    I'm also just now noticing that if I double click on a word document (already downloaded), it is not opening either (same problem as in my original post).
     
  4. statler macrumors newbie

    Joined:
    Jan 21, 2008
    #4
    This is a known bug resulting from the SP1 patch to Microsoft Office 2008. The bug prevents you from opening PC-created files (not just Word by the way, also Excel and Powerpoint) except from within the relevant Office application (File>Open).

    I don't know of a fix, it has been driving me crazy along with 1,000 other bugs and design flaws with Office 2008.

    Seriously, what's happened to Microsoft? Have all of their good programmers quite and gone to Google? This is amateur hour. I thought it was embarrassing enough that Microsoft even released Office 2008 without sufficient beta testing. But it's simply incredible that they could introduce such a basic and annoying bug in a service pack designed to fix bugs!
     
  5. Wicker macrumors regular

    Joined:
    May 11, 2008
    Location:
    Newcastle upon Tyne, UK
    #5
    So that's what it is, thank you for clearing it up. Hope they fix this soon because it's driving me insane!:mad:
     
  6. gehrbox macrumors 65816

    gehrbox

    Joined:
    Jul 5, 2007
    Location:
    Charleston,SC
    #6

    I found another thread reporting the same issue here in MacRumors.
    http://forums.macrumors.com/showthread.php?t=483646

    The following was posted in that thread as a workaround:

    Hope it helps you out.
     
  7. joebaroque thread starter macrumors newbie

    Joined:
    Jun 13, 2008
    #7
    Thanks for the info

    thanks for all your replies and info
     
  8. Father Jack macrumors 68020

    Father Jack

    Joined:
    Jan 1, 2007
    Location:
    Ireland
    #8
    I have experienced a similar problem trying to open documents produced by Pages and exported as Word files and sent as email attachments.
     
  9. Wicker macrumors regular

    Joined:
    May 11, 2008
    Location:
    Newcastle upon Tyne, UK
    #9
    Yeah, I used that as an alternative, but still annoyed me. What I do now is when it opens the blank document I will just click my Downloads stack to display it and drag the newly downloaded file to that blank document and voila! Opened.

    Here's hoping they fix that bug soon, though...
     
  10. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #10
    This is the reason I'm sticking with Office 2004 and iWork '08. Office for compatibility and iWork for stability and speed.
     

Share This Page