Problems w/ iMessage since JB (4S -5.0.1, VZW)?

HickDead

macrumors 6502a
Original poster
Dec 2, 2011
851
273
The past couple of days I'm been having major issues with iMessage on my Jailbroken 4S (Verizon). I'm wondering if this is somehow related to the JAILBREAK and if anyone else is experiencing similar issues? Here's what the problem I'm encountering:

a) I'm NOT receiving random iMessage texts from other people after they send it

b) When I send an iMessage, the bubble is blue and shoes "delivered" but then a couple of minutes later it re-sends the same text (duplicate) as a SMS text with a green bubble (and vice versa)

c) Some recipients are reporting that my iMessage is being delivered to them from my email address and NOT my cell #

Thus far, I have done a RESET on my Network Settings; Turned iMessage off and on; Signed out of my iMessage account and logged back in; I did a hard reset of my iPhone.

Could this possibly be an issue with Verizon's network.....or possibly even on Apple's end? Or perhaps caused by a Jailbreak tweak/app that I installed?

Any suggestions/advice is very much appreciated. THx

Edit: Here are the apps I have installed since JB (possible conflict?):

Ad Blocker
CallBar
iBlacklist
Gridlock
Winterboard (+ about 6 themes)
Springtomize 2
iFile
3G Unrestricter
InvisibleStatusBar
Lingual
Assistant Search
FakeClockUp
PkgBackup
PhotoAlbums+
 
Last edited:

LoloBond

macrumors 6502
Nov 21, 2011
436
1
c) Some recipients are reporting that my iMessage is being delivered to them from my email address and NOT my cell #
Go to Settings/Messages/Receive at/ Caller ID an make sure your phone number is selected. Other than I really don't know what it can be. Good luck!
 

EngageWithRage

macrumors 6502
Jan 30, 2012
272
0
Your girlfriend's house
Go to Settings/Messages/Receive at/ Caller ID an make sure your phone number is selected. Other than I really don't know what it can be. Good luck!
This, and I had sorta the same issue after the jailbreak with my iMessages not woring at all. I just dsiabled iMessaging and signed out, did a hard reboot, signed back in and turned on iMessaging and after a little while it worked
 

HickDead

macrumors 6502a
Original poster
Dec 2, 2011
851
273
Already tried that and I still couldn't get it to work properly. Ended up restoring my 4S and re-Jailbreaking it. So far, so good.....but I wasted about 3 hours of my life choosing this route. :D
 

MajesticNJ

macrumors regular
Jun 20, 2009
221
2
Central NJ
As posted in the following thread with the same/similar issue:
https://forums.macrumors.com/showthread.php?p=14252051&posted=1#post14252051

Fred

This happened to me yesterday and here is what I did to fix it.
I turned imessage off and yes my phone locked up. Press and hold sleep and home till phone hard resets.

Then I went back into settings and turned off Facetime.
Press and hold sleep till you get red swipe to shut down.

Shut down all the way then power back up again.

Go into settings and enable facetime and confirm the settings.
You will be asked for your account and password with Apple. Log in. Facetime gets activated. Then check imessage and it should be good too.

That fixed it all for me but not after going crazy for two hours trying to find out why it wasn't working.

Good luck.
 

HickDead

macrumors 6502a
Original poster
Dec 2, 2011
851
273
Thanks for posting that MajesticNJ! I'm sure it will come in handy down the road.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.