Problems when cloning hard drive

Discussion in 'MacBook Pro' started by andrew12090, Aug 3, 2009.

  1. andrew12090 macrumors member

    Joined:
    Jul 22, 2009
    #1
    Well I received my wd scorpio blue and tried to clone my original 160 gb hard drive. I can get the drive to mount and erased and formated but when I try to clone, it stops at 21.5mb copied and then after about a minute, it says that the drive has been ejected improperly and gives me that warning. I have also tried to just copy files over to the hd and it hangs also. Could this be the drive? I am using a brand new external enclosure also. Any help would be appreciated!

    for reference, I have reformated and erased the drive multiple times and taken out the drive, made sure it is seated, restarted the computer, and all to no avail. so any ideas?

    EDIT: I tried to mount the disk on windows and format and it would not allow it. So now, I will try to do it via the osx disc and the hd in the computer. any other solutions?
     
  2. m85476585 macrumors 65816

    Joined:
    Feb 26, 2008
    #2
    I had a drive with low-level corruption (caused by the power flickering while I was trying to format it). Once it was corrupted, neither Windows or OS X would format it without freezing/crashing. I hooked up internally by SATA o my Desktop and booted from the manufacturer's CD utility to format it. You could try that.

    Try to isolate the problem. Use another enclosure if you have one, try connecting the drive internally to a computer if you have one besides your MBP.
     
  3. andrew12090 thread starter macrumors member

    Joined:
    Jul 22, 2009
    #3
    I put the drive into my mbp and booted off the instal disk to no avail. I rma'd the hd this morning but am a little mad cause I will be without a larger hd for a week or more
     
  4. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #4
    When you booted off the install disk, did it fail while booting the install, or when trying to install? If it failed during booting the install, the OSX DVD is at fault.
     
  5. andrew12090 thread starter macrumors member

    Joined:
    Jul 22, 2009
    #5
    it failed to instal the OS. But I am sure it is the drive, as I tried to copy files to it and it hang up too.
     
  6. jamesryanbell macrumors 68020

    jamesryanbell

    Joined:
    Mar 17, 2009
  7. andrew12090 thread starter macrumors member

    Joined:
    Jul 22, 2009
    #7
    I rma'ed it today and got it sent out. now I have to make the 4gb of space left on my 160gb stock drive last till I get a new one
     

Share This Page