Problems when using VX nano mouse on MBP

Discussion in 'MacBook Pro' started by AkiNikoTanTan, Nov 16, 2007.

  1. AkiNikoTanTan macrumors member

    Joined:
    Jun 26, 2007
    #1
    I am not sure what i am experiencing right now is due to an faulty mouse or this is the way it behaves.
    It goes like this, whenever i leave my vx nano idling for a while, and when i try to touch it again, the cursor response instantaneously which is very very amazing compared to my previous logitech bluetooth mouse which shows a rather insignificant amount of delay (1-2 seconds) but it was irritating though. The weird thing that happens on my vx nano is that, no doubt the cursor is very responsive, i am unable to click on anything no matter how hard i try, initially i thought it was my MBP which went into sleep, however after i changed the settings to 'never sleep', i still encounter the same problem. I wonder if anyone using vx nano is experiencing this issue too. Thanks
     
  2. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #2
    I use a VX revolution as my primary mouse, and a VX nano as my secondary one. I use steermouse though. I haven't noticed any issues, but I'll be using the nano exclusively for about a week, so I'll let you know.
     
  3. mac jr. macrumors newbie

    Joined:
    Dec 28, 2006
    #3
    I have a vx nano as well with my mbp and noticed this and thought it was just a one time glitch. Then after reading your post realized it happens every time when I wake the computer up from sleep.

    The cursor works instantaneously, but I'm unable to click on anything. Are you using the logitech drivers? For some reason, I didn't notice this until I installed those drivers to take advantage of the extra buttons.

    I'll try uninstalling those and see if that fixes the issue.
     
  4. AkiNikoTanTan thread starter macrumors member

    Joined:
    Jun 26, 2007
    #4
    hahaha, so i am not alone. I am pretty puzzled because the cursor can response instantaneously and i just dont see why it just cant click. I believe its a software problem and not a hardware one.
    I did install the logitech whatever centre to use the other buttons, i like the hyper fast scroll but i dont like the hyper slow click, i dont like to trade off ..LoL.
     
  5. AkiNikoTanTan thread starter macrumors member

    Joined:
    Jun 26, 2007
    #5
    Finally i decided i should put the 2 cordless mouse to a simple test

    Vx nano Vs. v270 Bluetooth Mouse

    I left my MBP idling for about 15mins, then i try clicking the BT mouse first,
    as usual the cursor of the bluetooth mouse lag for a split second,however i am able to click on anything,(i.e right click, left click, scroll..etc...)

    Then i laid my hands on my vx nano, as expected, the cursor responded but it still cant click...WTF??? I went back to my BT mouse again to try, BT mouse was fine. Now i can conclude my MBP is fine and vx nano isnt.. =(
     
  6. byakuya macrumors 6502a

    byakuya

    Joined:
    Jul 26, 2007
    #6
    I have the vx rev. also but use it in combination with steermouse.
    used to have some issues with LCC installed but steermouse solved all of them. def. worth a try.
     
  7. AkiNikoTanTan thread starter macrumors member

    Joined:
    Jun 26, 2007
    #7
    Great Problem solved, i will nv install LCC again, its no command centre..LoL
     
  8. byakuya macrumors 6502a

    byakuya

    Joined:
    Jul 26, 2007
    #8
    good to hear that your problem was solved;)

    steermouse def. is the first choice for logitech mice fans.
     
  9. AkiNikoTanTan thread starter macrumors member

    Joined:
    Jun 26, 2007
    #9
    Thanks alot! I will definitely recommend steer mouse to my friends! Thanks again! :D
     
  10. Templex macrumors regular

    Joined:
    Jul 12, 2007
    Location:
    Los Angeles, CA
    #10
    I too have a VX Nano and use it as my primary mouse for my MBP.

    The source of my problems were LCC - got rid of that piece of **** and all the unresponsiveness and kernel panics were gone. You do know that LCC installs APE, right?

    I use my VX Nano with the built-in OS X drivers and it works perfectly fine. I do miss using the forward/backward buttons, though.
     

Share This Page