Problems with a game on the late 2012 iMac

Discussion in 'iMac' started by bluevast, May 23, 2013.

  1. bluevast macrumors member

    bluevast

    Joined:
    May 23, 2013
    #1
    I just bought a new iMac it's 3.2 Ghz Intel Core i5 8GB 1600 MHz DDR3 ram and NVIDIA GeForce GTX 675MX 1024 MB graphics Software is OS X 10.8.3 it's a 27" iMac. (My old 27" iMac did not have this problem it was a late 09 model) If I try to run the game Fallen Earth in high resolution on the toon select screen the arms and legs are gone if I start the game the same deal with all the toons in the game however everything else is fine and if i change the resolution to say 1600x1200 (4x3) the toons have limbs again but anything with resolution 1920x1440 (4x3) or higher and no limbs for the toons. I tried tec support and they said "best thing I can suggest in this case is to try updating your graphics card drivers to the latest version, and if they are already updated, try an earlier driver version which may be more stable with our Mac client". But I don't know how to do none of that Apple updates it's own drives right? And an earlier driver version? Is that even possible? Any suggestions, tips would be greatly appreciated.
     
  2. apedance macrumors member

    Joined:
    Sep 1, 2012
    Location:
    Vienna
    #2
    Hi,

    first of all ->

    Format your text better! Very unpleasant to read.


    You can't update or downgrade drivers in OS X!

    Are there any patches available for the game?

    Maybe run the game via bootcamp to be able to maintain the drivers?
     
  3. Serban Suspended

    Joined:
    Jan 8, 2013
    #3
    they are already working on new graphic drivers so hold on. I think they don't have the best drivers for those new kepler nvidia cards. i am sure we will see a 10% bump thanks to the drivers update. I think until 10th June they will release 10.8.4
     
  4. bluevast thread starter macrumors member

    bluevast

    Joined:
    May 23, 2013
    #4
    Sorry about the text I did a copy and paste from my email. And I've contacted the devs but they have yet to solve the problem.

    ----------

    That's great to hear thank you:)
     

Share This Page