Problems with AFP on network

Discussion in 'OS X Yosemite (10.10)' started by nebo1ss, Jul 6, 2015.

  1. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #1
    I am having a network issue that is driving me crazy. My network is relatively simple it has a Wan faceing router and an airport extreme set as a Bridge connected to the main router. There is a single subnet with address in the range 192.168.1.x

    My problem is with connecting multiple Apple computers to a Synology NAS using AFP. This has all worked previously but unfortunately i recently got a high speed internet access with a new router and also updated both OsX version and the Synology software in the last week I assume one or both of them may have something to do with it.

    If i put both the mac Mini and the Nas on the Airport extreme then they connect successfully. Similarly if I connect my MacBook pro on the wireless attached to the airport extreme it can connect to the NAS.

    However if either Mac is connected to the main router they will not connect to the NAS. Also if I put both the Mac and the NAS on the main router they will not connect. I am aware the Bonjour needs devices to be on the same subnet and will not traverse routers but there is only one subnet here with the Main router providing all the DHCP addresses.

    Is it possible that AFP is not compatible with the Router?

    leaving everything on the Airport extreme is not an option since 1. It does not have enough ports. 2. I want to use 802.11ac which my old Extreme does not support.
     
  2. nebo1ss thread starter macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    Well I have now solved the problem by switching to SMB instead of AFP. I guess Apple must be trying to force us to go to SMB. I had a bunch of start up scripts that did the link on restart and they just worked until this latest set of changes.
     
  3. nebo1ss thread starter macrumors 68030

    Joined:
    Jun 2, 2010
    #3
    As one problem with AFP is worked around another shows itself. Time machine will not work because it also uses AFP.
    A Google search shows lots of people having AFP problems wtih Yosemite and AFP but I am yet to find a solution to my particular problem. Apple certainly seems to have broken something.
     

Share This Page