Problems with Airdrop

robbiebray

macrumors newbie
Original poster
Oct 5, 2008
3
0
Hi

I'm having some issues with Airdrop and I'm confused to the point that I need some help. I have looked through the discussions and have tried various options, but no joy.

So, here's my problem. I'm trying to share some files between 3 computers:

1) 2010 iMac running lion
2) Late 2008 MBP running lion
3) Mid 2010 MBA running lion

The issue is that the MBA can be seem by both the MBP and the iMac on the airdrop radar. The iMac CANNOT see the MBP and vice versa, but the iMac can see the MBA. However, the MBA cannot see the iMac. The MBP can be seen by the MBA. Confused? I am!

I know that only certain hardware models can work with airdrop - all of mine are sweet.
I know about the P2P network that is created, so that's all good - it's not my wireless network.
At the moment, just for testing, the hardware is all on the same desk, so distance is not an issue.
All are updated to the latest standard.
I have been into system prefs and have compared all of the security stuff - All have Finder and File Sharing set to allow incoming and coutgoing connections.
File sharing is set to on.

Due to the fact they can all see something, I cannot work out where the issue lies. Any help on this would be really gratefully received.

Thanks in advance

Rob
 

robbiebray

macrumors newbie
Original poster
Oct 5, 2008
3
0
Hi

I'm using a BT Homehub 2, but as I understand it, it should not make a difference as Airdrop works by the 2 computers setting up an independant network.

The only firewalls are on the macs themselves, which in theory should not cause an issue.

Please let me know if you are aware of anything different.

Cheers

Rob
 

abgarman

macrumors newbie
Feb 1, 2012
3
0
I have the same problem. My MBPro 17" (mid 2011) can not be seen by other computers on airdrop (iMac 27" late 2011, MacMini mid 2011), but I can see them on my MBPro. I can also send files to other computers - when the files are being sent, MBPro appears on other machines during the transmission, when the transfer is done - it disappears again. Therefore I can only send files from my MBPro, but not to MBPro.

HELP?

Specs of network - Airport Extreme 2011 (802.11 n). No firewall. I had LittleSnitch installed, but deleted it from apps (not sure though, if I removed it completely - maybe I need to clean it up even further somehow...?)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.