Apple TV Problems with AirPlay after Jailbreaking ATV2

Discussion in 'Jailbreaks and iOS Hacks' started by Junkdumpster, Apr 8, 2012.

  1. Junkdumpster macrumors newbie

    Joined:
    Mar 21, 2012
    #1
    The title pretty much says it all. I jailbroke my ATV2 running iOS 5.1 (or whatever the most recent software update is...I've heard people use 5.01, which I thought was wrong) last night using seas0npass (tethered, obviously). Everything was going great, until today when I discivered some serious roadblocks trying to use airplay.

    First thing I noticed was AirPlay mirroring from my iPhone 4s (running iOS 5.1) was weird. It took a while to load on the screen, and when it did show up, it wouldn't display anything but the menu (games, safari, even iBooks wouldn't show up on the screen. It would just sit on the menu). I then tried to stream video from the native video app, through normal airplay rather than mirroring. No luck. Same with my iPad 1 (jailbroken on iOS 5.1). Music, however, streams just fine from all music apps.

    I had no luck using AirPlay in XBMC either, though since that program is still sort of new on iOS 5.1, I'm not really concerned about that, unless the issues are the same.

    Any suggestions? Could the jailbrake be causing problems and if so, is there anything I can do? I didn't have any problems with airplay and my iphone before, so this has definitly started after jailbreaking, even if it is just a coincidence.

    UPDATE: I rebooted the ATV2 and did a restart on my phone, and it seemed to help, at least for a couple of minutes. I was able to get a game up. But upon exiting, it froze up on me again. So rebooting isn't really a solution.
     
  2. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #2
    If you're running XBMC, you have to turn airplay off on the ATV and on in XBMC settings otherwise they conflict.. It's in the manual you read. you did read it like all of us, right? :) :)

    Kidding on the manual. I haven't tried it with v5 though, I refuse to do tethered so I'm still on an older version.. 4.4.4 without checking, don't think I went to 5 since it's so solid where it is.
     
  3. Junkdumpster thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #3
    Tried disabling AirPlay in XBMC as you suggested, rebooted, but found that nothing had changed. Maybe there is some kind of issue with AirPlay and the iOS 5 jailbreak.

    Trust me, I would have loved to be on a much more stable, untethered 4.4.4 jailbreak, but the lovely Craigslist seller that I bought from must have thought he was being extra nice by upgrading and not telling me, despite the fact that I specifically requested he not. No SHSH plus airplay problems=me very unhappy.
     
  4. pdafan macrumors member

    Joined:
    Aug 2, 2011
    #4
    Don't think it make any difference if the does not have the SHSH saved.
    If he has saved up in Cydia, then even it is upgraded now, you would be able to downgrade.
     

Share This Page