Problems with Airport Extreme BaseSation and xBox 360

Discussion in 'Mac Accessories' started by odriscs, Feb 25, 2008.

  1. odriscs macrumors newbie

    Joined:
    Aug 23, 2006
    #1
    Hi all,

    Apologies if this is in the wrong forum but this is the only place I felt it fit in. Basically the problem is connecting my xBox 360 wirelessly to my Base Station. It's an Xbox 360 Elite and I plug in the wireless connector and it recognises it all fine and dandy and when I search for my network it finds it no problem but when I select the network and try to run Xbox Live Test Connection it tells me that yep its using the wireless connector but nope it hasn't joined the wireless network. If I plug in the 360 directly to the BaseStation with an ethernet cord it connects up no problem. I've downloaded any and all available updates and still no joy, none of the updates seem to address this issue. From my searches of various forums a lot of people had this problem with their BaseStation/Xbox set-up when the BaseStation was initially launched and I've tried nearly every solution that's been posted and nothing works. Wanna see if anybody has a solution before I ring Xbox Support where I imagine they'll fob me off with some Microsoft bull***** about "well that's not a compatible router and we didn't feel the need to inform you of this before you spent €95 on it and now that you've opened the box we can't accept it back" Grrrrr! :mad:

    Any help would be much appreciated! :)
     
  2. odriscs thread starter macrumors newbie

    Joined:
    Aug 23, 2006
  3. richpjr macrumors 68030

    richpjr

    Joined:
    May 9, 2006
    #3
    I recently picked up the XBox wireless adapter because I wanted to move my Box 360 out of my office and into my living room on my big screen TV. I ran into the same issue you described and did a little searching about it. As you discovered, these two devices don't play well together. I have read some people claiming to that it will work if you drop the Airport Extreme down to G only and turn off WEP. Since I am not willing to do that I returned the Microsoft adapter and am looking at this:

    http://www.linksys.com/servlet/Sate...nksys/Common/VisitorWrapper&lid=4757740536B01

    I am having other issues with my Airport Extreme (locking up several times a day) and may consider dumping it for a different wireless router.
     

Share This Page