Problems with Boot Camp on MBP

Discussion in 'Windows, Linux & Others on the Mac' started by ped, May 22, 2006.

  1. ped macrumors regular

    Jan 31, 2005
    I got a MacBook Pro 2.0Ghz a couple of days ago. Very nice machine but I'm having major issues with getting Boot Camp to work. On first boot I registered my Mac and it told me I had a bunch of updates to apply, including a CSM firmware update. I applied them all at once, it rebooted and said CSM was updated. Then I tried to install BootCamp but it complained about needing newer firmware. I looked and found out there was a different firmware update, 1.0.1, for the MBP so I installed that too and BootCamp was OK with things. I partitioned the disk with BC, burned the drivers CD, and rebooted with XP CD in the drive. Instead of seeing the Windows install starting I get a corrupted screen with patches of colors all over. I've tried several different XP SP2 CDs and none have worked (all same result). So then I figured I'd try restoring (or at least try - heard the firmware will only fall back if the firmware installed is corrupted or otherwise incomplete) the firmware. I got the Firmware Restoration CD off, burned it, and proceeded to boot from it by holding down the "C" key on a reboot. It did the exact same thing the XP CD did! Now I know the system can indeed boot from a CD, because I reinstalled OS X in troubleshooting this problem by rebooting while holding Option to get the boot choices menu and choosing the DVD 1 of the install.

    Anyone know what's going on here? Is this a corrupted firmware thing? If so how can I resolve it?
  2. bobber205 macrumors 68020


    Nov 15, 2005
    What else did you install when you first got the machine?

    It may have been one of those "other" things that corrupted the install.

    If you're desperate to use XP, and if you don't have anything valuable on the computer already, just wipe it clean and start over.

    That usually solves it. :D

Share This Page