problems with bootcamp new mbp

Discussion in 'Windows, Linux & Others on the Mac' started by nihnightmare, Jun 8, 2007.

  1. nihnightmare macrumors newbie

    Joined:
    Jun 8, 2007
    #1
    I got a macbook pro yesterday, so its one of the new ones, if that matters, and i tried to install bootcamp, the first thing that happened was when boot camp was partitioning my drive, i choose 32 gigs it told me that there was a volume error and to run the disk utility. So i ran the disk utility and it told me there was a minor error that could not be repaired so i ran disk utility from the cd that came with the mac and fixed the error. I then tried to install bootcamp again, this time I got past the partitioning and installed xp with service pack 2 on my mac book pro. I then insterted the drivers cd and it got about half way through with installing then xp froze and i had to do a manual shut down. When i booted back up it went to the blue screen and said something which i now cant remember. after that i erased bootcamp and unpartitioned the drive. I checked and there were no errors on the drive and i have been weary to try boot camp again. Does anyone know why this happened, should i be nervous for the state of my mac, it is only 1 day old. Does anyone have any advice or experiance with this? please help me. thanks
    should i use 1.3, should i use xp or vista?
     
  2. reflex macrumors 6502a

    Joined:
    May 19, 2002
    #2
    If you haven't already, you should definitely use Bootcamp 1.3 instead of an older version for the new MBPs.
     
  3. c-Row macrumors 65816

    c-Row

    Joined:
    Jan 10, 2006
    Location:
    Germany
    #3
    Similar problem here... Disk Utility keeps telling that there is an error which can't be corrected. Unfortunately I am far away from the iMac right now, and my wife claims that the original OS X CDs are not in the package... (like they would be anywhere else... :rolleyes: )

    How can she fix this?
     
  4. ejuanpiman macrumors member

    Joined:
    Jun 6, 2007
    #4
    Ok for starters YES use bootcamp 1.3, it has new chipset drivers... wich are specifically for the NEW SR MacbookPro's. wich would explain any freezes over installing them if you were using the old bootcamp.
     
  5. Membrain macrumors member

    Membrain

    Joined:
    Jun 5, 2007
    Location:
    Melbourne, Australia
    #5
    startup problems after aborted XP install

    I installed Bootcamp 1.3 - fine,

    Started XP install from an old disk, didn't get the option of formatting as FAT32 even though it was a 32gig partition as suggested by bootcamp.

    Started formatting as NTSF and noticed it incorrectly stated the partition size (about 130,000meg I think ).

    Let it get 3/4 of the way through which took a really long time (about an hour) and decided to force shutdown the computer by holding down the power button.

    When I restarted the screen was white (as it is when first started) with no message or graphics and the XP install disk is still in the drive (I hear it spin up when I turn the computer on). I shutdown and restarted holding down the eject key, the mouse button, the option key, the C key and nothing has made any change or ejected the disk.
    I have tried command-option-p-r to reset the PRAM with no result. The only change now after letting the computer sit for 5 or 6 hours is it will shutdown itself if I startup with with a key pressed.

    It is a 2.4 Ghz/2Gig Ram/15" with 256 VRAM. I have had it for 2 Days!!!

    Any ideas about getting that damn disk out? Any help with getting past the white screen?
     
  6. capoditutti macrumors 6502

    capoditutti

    Joined:
    Nov 11, 2006
    Location:
    Cambridge
    #6
    Force shutdown, and then give it a few seconds just to let the hard disk spin down. Then press the power button, and press and hold the eject key for a while... it can take up to 20 seconds or more for the system to go thru everything but it will eject the disk... I had this problem last night, and i'm now going to set the machine up (MBPro stock 2.13 C2D) with Bootcamp 1.2, bcoz 1.3 aint working like 2 did...
     
  7. Membrain macrumors member

    Membrain

    Joined:
    Jun 5, 2007
    Location:
    Melbourne, Australia
    #7
    I have already tried this, as i stated in my original post.
    Having now taken it into a service centre, I've been told the only way to remove this disk is to disassemble the computer and physically remove the disk.
    Apple will not cover the cost of this ($150) even though the laptop is 2 days old as bootcamp is not covered by any warranties - use it at your own risk!
     

Share This Page