Problems with brand new iPhone 8GB.... help please

Discussion in 'iPhone Tips, Help and Troubleshooting' started by gtx3, Apr 29, 2008.

  1. gtx3 macrumors newbie

    Joined:
    Apr 29, 2008
    #1
    Hello,

    I received today my brand new iphone 8GB from UK.
    I'm having some problems, maybe due some misconfiguration....

    1) Can't hear anyone on the other side (updated: removed the plastic cover and now sound is ok!)
    2) Everytime i try to call a number using key keypad, when i start writing the number it ALWAYS sends me back to the main menu, not allowing me to dial any number! I only can call someone if i add his/her number to the phone book and dial directly from there..
    3) Everytime someone calls me, i don't get the call. Doesn't ring, neither vibrates. Only shows me like a small "loading image" on the center of the screen. Nothing else....
    4) When receiving a SMS, when i click on SMS icon, it takes me back again to the main menu, 2-3 seconds after...


    What can i do? Is this any misconfiguration? firmware? software problem?
    The phone is new in the box, never used.
    I tried already a reboot of the phone, pressing both top and bottom buttons, but still with this problems...

    firmware is 1.1.2
    Phone came with an O2 SIM CARD. With this SIM CARD there is none of the above problems....
    Please help!
     
  2. moel macrumors 6502

    Joined:
    Nov 7, 2007
    #2
    Are you using the o2 sim with the phone?

    If you aren't using the o2 sim, then have you jailbroken and unlocked the iPhone?

    If you haven't jailbroken and unlocked it properly it could well exhibit what you describe.
     

Share This Page