Problems with Dock

Discussion in 'Mac Basics and Help' started by m82palmer, Aug 3, 2006.

  1. m82palmer macrumors newbie

    Aug 3, 2006
    About 3 weeks ago my system went mad.

    The Dock stopped coming out of hiding or if it did magnification did not work.

    The top level menus also semi stopped. When i clicked on a header it opened the menu, however if there was an expand arrow (like Dock or Location from the apple button) it would not expand if i hovered my mouse over it. If i clicked it, it would exit the menu.

    So i restored my it back to factory settings. All is fine for a few weeks, an now it has happened again.

    I have tried running Cocktail, Running Verify Disk Permissions and Disk, I have also tried "Sudo killall dock"

    Any ideas? or should i just restore it again?


    Expose also has stoped working

    Edit 2

    When i drag a file over the dock (as if i was going to put it in the bin) it works fine :S

    When i click on the top menu, if i hold down the left mouse button, it all works.

    Could it be a problem with the Mouse settings?

    Edit 3

    When i enable Mouse Keys in universal access everything works fine, which leads me to belive the problem is with the mouse. I have tryed a different mouse though and still the same :S
  2. m82palmer thread starter macrumors newbie

    Aug 3, 2006

    I reset the PRAM and it sorted it self out. Not sure how or why, but it works :eek:

Share This Page