Problems with Garageband and E-MU 0404 USB

Discussion in 'Digital Audio' started by janpedro, Jan 6, 2009.

  1. janpedro macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Finland
    #1
    Hi!
    I recently bought a MacBook Pro and have used it with Garageband a couple of weeks without any problems. However, as I installed the drivers for the interface I've used with my PC (E-mu 0404 USB) and plugged it into my mac, Garageband won't boot up at all.

    I've deleted the E-mu drivers and reinstalled Garageband but with no luck - Garageband still won't boot up. Some other guys had problems with this particular interface and Garageband, but I didn't find any concrete solutions.

    Suggestions?




    Process: GarageBand [144]
    Path: /Applications/GarageBand.app/Contents/MacOS/GarageBand
    Identifier: com.apple.garageband
    Version: 4.1.2 (248.7)
    Build Info: GarageBand_App-2480700~16
    Code Type: X86 (Native)
    Parent Process: launchd [75]

    Date/Time: 2009-01-06 12:43:21.273 +0200
    OS Version: Mac OS X 10.5.6 (9G55)
    Report Version: 6

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
    Crashed Thread: 8
     
  2. janpedro thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Finland
    #2
    Reinstall

    I guess I could reinstall Leopard if there aren't other options?
     
  3. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #3
    What this says to me is that you are seeing an error in a device driver. An uninitialized pointer is being used.
     
  4. janpedro thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Finland
    #4
    The error report continues like this:


    Thread 0:
    0 libSystem.B.dylib 0x96711771 spin_lock + 5
    1 libSystem.B.dylib 0x9673b567 pthread_mach_thread_np + 39
    2 ...lodyneEssentialRewireDevice 0x1886b7ab GNThread::getThreadPriority() + 123
    3 ...lodyneEssentialRewireDevice 0x1886bad0 GNThread::setThreadPriority(int) + 178
    4 ...lodyneEssentialRewireDevice 0x18889d44 GNMessagePort::registerMessagePortWithName(GNString*, GNData* (*)(GNMessagePort*, GNData*), int, int, GNDictionary*) + 304
    5 ...lodyneEssentialRewireDevice 0x1882bdbe GNReWire2AudioDeviceHost::create() + 172
    6 ...lodyneEssentialRewireDevice 0x18829f3f RWDEFOpenDevice + 89
    7 ...opellerheads.rewire.library 0x1878084e 0x1877c000 + 18510
    8 ...opellerheads.rewire.library 0x187809b8 0x1877c000 + 18872
    9 ...opellerheads.rewire.library 0x187838e0 RWPUnregisterDeviceImp + 5438
    10 ...opellerheads.rewire.library 0x18781689 RWM2OpenDeviceImp + 57
    11 com.apple.garageband 0x00c9c2a9 0x1000 + 13218473
    12 com.apple.garageband 0x00798e8f 0x1000 + 7962255
    13 com.apple.garageband 0x004a3beb 0x1000 + 4860907
    14 com.apple.garageband 0x004ad0a5 0x1000 + 4898981
    15 com.apple.garageband 0x0037edac 0x1000 + 3661228
    16 com.apple.garageband 0x0037f84c 0x1000 + 3663948
    17 com.apple.garageband 0x00349fa2 0x1000 + 3444642
    18 com.apple.garageband 0x002611a3 0x1000 + 2490787
    19 com.apple.garageband 0x000648c9 0x1000 + 407753
    20 com.apple.garageband 0x00063f55 0x1000 + 405333
    21 com.apple.Foundation 0x94866f1c _nsnote_callback + 364
    22 com.apple.CoreFoundation 0x96eee8da __CFXNotificationPost + 362
    23 com.apple.CoreFoundation 0x96eeebb3 _CFXNotificationPostNotification + 179
    24 com.apple.Foundation 0x94864080 -[NSNotificationCenter postNotificationName:eek:bject:userInfo:] + 128
    25 com.apple.Foundation 0x9486d8c8 -[NSNotificationCenter postNotificationName:eek:bject:] + 56
    26 com.apple.AppKit 0x93e2e91d -[NSApplication finishLaunching] + 515
    27 com.apple.AppKit 0x93e2e3a3 -[NSApplication run] + 83
    28 com.apple.AppKit 0x93dfb8a4 NSApplicationMain + 574
    29 com.apple.garageband 0x0017fe6b 0x1000 + 1568363
    30 com.apple.garageband 0x00002bd2 0x1000 + 7122
    31 com.apple.garageband 0x00002af9 0x1000 + 6905


    I did also install the Melodyne Essential after having installed the E-mu drivers. According to the report, Essential is at least a part of the problem, isn't it? Weird, I've deleted that very program as well...
     
  5. janpedro thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Finland
    #5
    Problem solved

    After I deleted some hidden Melodyne Essential files garageband works again!
     
  6. DavinaScheper macrumors newbie

    Joined:
    Jan 9, 2009
    #6
    Can you tell me which files you deleted specifically? I'm having the same problem, read it everywhere on forum, but no solution yet. You're the first!
     
  7. DavinaScheper macrumors newbie

    Joined:
    Jan 9, 2009
    #7
    Btw, would this mean that if you don't install the plugins (melodyne appears to be the problem), you wouldnt have a problem at all??
     
  8. Janus85 macrumors newbie

    Joined:
    Mar 16, 2009
    #8
    For anyone who still needs to know how to find those hidden files, follow these instructions:

    In order to get Logic working again, navigate to the following directory:

    /Library/Application Support/Propellerhead Software/ReWire

    Once in the ReWire app support folder, you’ll see a bunch of files (the number of these will vary depending on how many ReWire apps you use). Two of these will be Melodyne files; simply trash them and empty the bin. For one of those files, you will be asked for the admin password on your computer. Don’t be alarmed by this - if you want to get back into Logic, you’ll need to trash both files.

    Once the trash is emptied, try starting Logic again. It’ll most likely check all your Audio Units, and then you’re up and away again.

    If this doesn’t work go to the Melodyne web site and follow the instructions to uninstall it.

    This was the final thing I needed in order to get Garageband and Logic working once again. Hope it does the same for you!
     
  9. nbarella macrumors newbie

    Joined:
    Jun 1, 2009
    #9
    it worked!!

    I have been trying to get my garage band to work for several months and this fixed it!!

    thank you!

    -nic
     
  10. tucogm11 macrumors newbie

    Joined:
    Jun 3, 2009
    #10
    thanx!

    awesome! thank you.. works for pro tools also
    hug
    t.



     
  11. epicbeats macrumors newbie

    Joined:
    Mar 23, 2010
    #11
    logic not working because of E-MU 0404

    Hey im freaking out a bit because ive looked up all these conclusions you guys have posted to fix it and I have deleted everything and still not working. No more rewire and no more melodyne and it is still not initiallizing core audio. and in the error report it says mellodyne rewire in it and I dont know where it is located. Please help me fix this I need this to be right.:mad:
     

Share This Page