Problems with iMovie

Discussion in 'macOS' started by AnrBjotk, May 15, 2012.

  1. AnrBjotk, May 15, 2012
    Last edited: May 15, 2012

    AnrBjotk macrumors regular

    Joined:
    Jul 4, 2010
    #1
    So, I finally managed to fix Quicktime, meaning I could finally use iMovie again.
    However, though iMovie itself works like it should, I cannot export or share any videos. Every time I either try to share a video on youtube or export a clip, I just get a error message.
    The message I receive is something like "Cannot prepare project for sharing. An error occured (-50)"

    So, what do I do? At first I thought it was the disc, which was damaged, but I managed to repair by booting. But even after that, iMovie wont export.

    What can I do? Please help, I miss sharing videos on youtube
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    Can you Share>Export Movie? If so do that then upload via the YouTube webpage.
     
  3. AnrBjotk thread starter macrumors regular

    Joined:
    Jul 4, 2010
    #3
    No, like I wrote, or tried to, both sharing on youtube and exporting (either export video or export to quicktime) create the same responce "Error (-50)"
    And "(-50)" means, according to Apple: ""Error in user parameter list"

    And I have tried to remove and recreate the com.apple.imovie.plist.
     
  4. AnrBjotk thread starter macrumors regular

    Joined:
    Jul 4, 2010
    #4
    A little update:

    I installed Final Cut Pro to try another program (a friend loaned me the disc)
    and this time I got another error message: "No codec installed".

    This leads me to conclude that the fault must be with Quicktime. Recently I started another thread here about that, I had deleted/uninstalled Quicktime by mistake and had trouble reinstalling (OS X claiming to already be installed). I finally resolved the issue, with help from here, by installing an old-ish update patch (10.6.8 combo update), which finally made me able to open iMovie again (which I could not do without Quicktime). Through this update I could install or open Quicktime 10.0., however the icon in dock shows a template mac program image, not the quicktime. This leads me to conclude that there is something wrong with Quicktime, making some codecs or similar unavailable, making iMovie and Final Cut Pro unable to work properly.

    Sorry, way too much text, hope someone will bother to read it, cause I really need some help here guys, you've helped me before, come ooon. Pretty please...
     
  5. Stormybot, Dec 19, 2012
    Last edited: Dec 19, 2012

    Stormybot macrumors member

    Joined:
    Apr 19, 2004
    #5
    Hi. I just wanted to see if anyone found a solution. This just started happening for me on my Mac Mini.

    This happens when exporting a movie (Share -> Export Movie). It goes through the entire export, which I am sure many of you know can take a good amount of time, and then when it is done, spits out this error.

    Hardware: Mac Mini 2.4 GHz Intel Core 2 Duo w/ 8 GB of RAM
    Software: iMovie 9.0.8, OS X 10.8.2

    The source of the video (1080i) is coming from an external hard drive that is Mac OS Extended (Journaled) formatted and the exported file is trying to be saved onto the Desktop of the Mac Mini which is Mac OS Extended (Journaled) as well.
     
  6. bigpoodles macrumors newbie

    Joined:
    Jul 27, 2015
    #6
     
  7. bigpoodles macrumors newbie

    Joined:
    Jul 27, 2015
    #7
    2015 and this is still happening. The fastest fix is to export project to m4v, then open iDVD and import the m4v. Works like a charm.
     
  8. ImBuz macrumors regular

    ImBuz

    Joined:
    Oct 23, 2014
    Location:
    California

Share This Page