Problems with iPhone 4 screen after replacement

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ZombieTrev, Jun 21, 2013.

  1. ZombieTrev, Jun 21, 2013
    Last edited: Jun 21, 2013

    ZombieTrev macrumors newbie

    Joined:
    Jun 21, 2013
    #1
    Hi all. Just joined the site so please be kind :)

    I have changed the screen of 4 or 5 iPhones now and never had a problem until now.

    I bought 1 with a broken front and back screen and an unresponsive bottom half of the screen. I have changed the screen and digitiser and when I first tested it, it all seemed to work perfectly.

    Then I put a sim card in and the back case on and the phone suddenly got the white screen of death.

    After putting it into recovery mode and restoring the phone, it again seemed to fix it, but after locking the screen and then unlocking it, the screens has a lot of red horizontal lines that will not go away...

    [​IMG]

    Anybody know what could be causing this? I have checked all connections and tried restarting the phone but so far, nothing has worked. It is just strange that it was working perfectly twice and then each time has gone wrong within 5 minutes and has had a different problem each time...

    Any help would be greatly appreciated. Cheers

    ---UPDATE---

    I just did a screen shot on the phone and then loaded it up on my PC and the red lines were not in the picture... This to me suggests that it is a problem with the screen or the connections?

    So I turned the phone off and disconnected everything and put it back together again and upon turning it back on, the screen is white again...

    I'm currently in recovery mode yet again doing yet another restore. Does anybody have any clue what could be causing this? As I am stumped.

    ---UPDATE---

    I'm aware that I am essentially talking to myself here but it is now working again and (so far) isn't white screening or red lining... Fingers crossed it was just a loose connection that was causing the red lines, but the white screen is still confusing me.

    What could have caused the white screen of death baring all of the above in mind? I know it is hopefully fixed now but I would like to understand the problem if possible?
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    it looks like you simply got a bad screen. i would return it to where you bought it from and get another one.
     
  3. ZombieTrev thread starter macrumors newbie

    Joined:
    Jun 21, 2013
    #3
    Yes, I am starting to think that as well.

    After leaving the phone on charge for a few hours yesterday, I came back to it and the red lines had returned. It seems so temperamental...

    Has anybody had anything like this before?
     
  4. ZombieTrev thread starter macrumors newbie

    Joined:
    Jun 21, 2013
    #4
    How has this thread had 978 views and only 1 reply???

    Please people, at least acknowledge me... I feel invisible!
     
  5. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #5
    because the problem is obvious and you have already been given the answer. if you want to really feel invisible, ill delete my posts. do what any other person with common sense would do. contact the seller you got the screen from, let them know it appears to have a manufactures defect and then do one of two things....

    1.) request a replacement screen from them and return this one

    2.) dont buy a cheap screen from an unreliable source like amazon or ebay. pay the money and get a quality screen thats been tested for functionality from icracked.com or ifixit.com.
     

Share This Page