Problems with iphone remote

Discussion in 'Mac Basics and Help' started by mitler, Dec 7, 2009.

  1. mitler macrumors newbie

    Joined:
    Dec 7, 2009
    #1
    Someone in my house have made their iphone as remote for my itunes by using the wifi, and it's really pissing me off:mad:. Is it possible to block this iphone or something from my mac?
     
  2. Rampant.A.I. macrumors 6502a

    Joined:
    Sep 25, 2009
    #2
    He's probably using a program called Mobile AirMouse.

    Search for the program, open the control panel and disable it.

    It may also be in your startup items folder as well.
     
  3. mitler thread starter macrumors newbie

    Joined:
    Dec 7, 2009
    #3
    Nope, didn't have it, but I think he uses the app remote and I don't know ho to disable it from my mac.
     
  4. stayupforever99 macrumors newbie

    Joined:
    Apr 2, 2009
    #4
    I think the solution to your issue is to disable the Bonjour service as this is how the remote app talks to itunes.

    1 Go to Utilities

    2 Open terminal

    3 Then enter the code here

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    now the remote app will not be able to see your itunes, this will also disable other computers on you network seeing you so easily

    4: At some point you may want to turn this back on for file sharing or some other reason so you would enter this in to terminal

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    5: If you are using windows have a look at this link

    ttp://www.raymond.cc/blog/archives/2008/02/10/how-to-uninstall-or-remove-bonjour-mdnsresponderexe/

    Hope this helps
     
  5. mitler thread starter macrumors newbie

    Joined:
    Dec 7, 2009
    #5
    well, it the first commando worked (sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
    ) but the other one didn't...

    Some help?
     
  6. stayupforever99 macrumors newbie

    Joined:
    Apr 2, 2009
    #6
    Sorry don't understand what do you mean the second command did not work? Did you get an error message or did the service fail to reload?

    Try this

    launchctl load /path/to/relocated/com.apple.mDNSResponder.plist
     
  7. mitler thread starter macrumors newbie

    Joined:
    Dec 7, 2009
    #7
    The commando said it was loaded but i didnt find the itunes with my ipod, but im gonna try some more times first.
     
  8. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #8
    iTunes -> Preferences, Devices tab. At the bottom you can disable the remote function or forget the pairings of all remotes previously authorized.
     

Share This Page