Problems with iPhoto '09

Discussion in 'Mac Apps and Mac App Store' started by natewsmith, Sep 30, 2009.

  1. natewsmith macrumors regular

    Joined:
    Sep 9, 2007
    Location:
    Santa Clara, CA
    #1
    Hi everyone,

    Here's my problem and I hope it's an easy fix.

    I have a vast collection of photos. They are all there on my mac but iPhoto continuously doesn't show thumbnails even when I tell the program to fix them several times.

    The second problem is, when I click on a photo it initially shows up but then iPhoto says it can't find it and it asks me to locate it. Well the photo never went anywhere and it is there where it says it is but it is grayed out.

    I've tried repairing iPhoto and have even moved the pictures to a different hard drive and have started over but nothing seems to help.

    Does anyone have any ideas?

    Thanks,

    Nathan
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Sounds like perhaps your iPhoto library is corrupt. Did you try rebuilding it
     
  3. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #3
    Sounds like you have been messing around in the iPhoto library in finder. Any time anything is done to a photo in that library, iPhoto will not be able to find it correctly. You must stay out of that folder if you want to use iPhoto.

    I think the suggestion of the total rebuild (not just of the thumbnails) is your first/best shot right now. Try that and report back.
     
  4. natewsmith thread starter macrumors regular

    Joined:
    Sep 9, 2007
    Location:
    Santa Clara, CA
    #4
    I stated above that I've tried rebuilding it. I've rebuilt it several times and nothing seems to work with fixing this. I've not used the finder in locating pictures.

    I've rebuilt the whole thing, not just the thumbs.
     

Share This Page