Problems with Lag in iTunes

Discussion in 'Mac Apps and Mac App Store' started by mtfield, Jun 13, 2008.

  1. mtfield macrumors 6502

    Joined:
    Jan 9, 2008
    #1
    To help with space issues I recently moved my entire tv show library to an external hard drive connected by a usb 2.0 to my airport extreme base station. I then set up itunes to recognize that the tv shows were now on the external drive, and all of this went smoothly. My problem is when I open the show in front row or in itunes it takes a second to load (which I know is normal) then starts playing... pretty soon after though it begins to hiccup and lag and freeze/jerk.. I have read other people with a similar setup and they seem to be having this work fine. My AEBS is set up with the 802.11n Only (5GHz) setting and it's all running on my macbook pro (2.4 GHZ core 2 due, 4gb ram) so my set up should preform this simple stream seamlessly no? maybe I have a setting wrong or something? any ideas??? thanks I was seriously looking into an apple tv, but if it does this same jerkiness then it would be unwatchable.. thanks for any help!
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    One thing you did not mention, wifi or direct cable?
    I have the same setup, macpro, atv, etc etc. Wifi (g) and there is a slight delay when I choose a file for the first time, but no hiccups. I use a PowerBook 1.67ghz and a MacPro (brand new) and it does it on both. The behavior you describe doesn't happen to me on either machine.
     
  3. mtfield thread starter macrumors 6502

    Joined:
    Jan 9, 2008
    #3
    The direct cable goes into the airport extreme, but i connect to it via wifi.. my whole plan was to be as wireless as possible.. yea other people don't seem to have this problem which is what confuses me..
    *UPDATE*
    I turned off my wifi and plugged an ethernet that is running from my AEBS into my laptop and the video played flawlessly no jerks or hiccups.. but as soon as I unplug and go back to wifi there is a problem again. Just some other info I live in a apartment building in chicago. The apartment is small though so I won't ever have distance issues, but there are many other routers around me.. i dont know if that causes a problem or not. Also the airport is set up in an open from desk compartment about 2 feet from the ground. On the sides of it is where I have two hard drives set up, underneath I have a power hub that has a backup battery in it and then on top of the extreme i have a usb hub.. I dont know if any of that info helps at all...
     

Share This Page