Problems with MBP '10 and Advanced Drive Format

Discussion in 'MacBook Pro' started by rev.b, Mar 16, 2011.

  1. rev.b, Mar 16, 2011
    Last edited: Mar 16, 2011

    rev.b macrumors regular

    rev.b

    Joined:
    May 1, 2009
    Location:
    Portugal
    #1
    Hi there. I have a 15" MBP '10 (i5 2.4 Ghz)

    I'm having troubles with my new WD Scorpio black 750 Gb.
    After installing it, partitioning and formatting, I copied my old system Carbon Copy Cloner, booted and everything seemed fine.

    But after a while, I'm getting disk corruption, every time with the same error:

    [​IMG]

    This is right after I repaired the disk after booting with the OS X disk and running disk utility.

    SMART status is OK, and I already ran a surface scan with techtools pro, no bad blocks found, so physically, the hard drive seems fine.

    What should I do? Shouldn't OS X support advanced drive format (4k) drives? Is this because I'm cloning the disks? Should I make a clean install?

    Help me please, I really am lost here.
     
  2. mgartner0622 macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #2
    Is this from the disk utility while Mac OS is running or off of an install DVD?
    I would recommend trying an install DVD.
     
  3. rev.b thread starter macrumors regular

    rev.b

    Joined:
    May 1, 2009
    Location:
    Portugal
    #3
    This is the first boot from the hard drive *after* repairing it with the install DVD, that said the repair was successful.

    Booting with the install DVD and running disk utility gives the same error after that.
     
  4. rev.b thread starter macrumors regular

    rev.b

    Joined:
    May 1, 2009
    Location:
    Portugal
    #4
    Any ideas? Is this a bad drive?
    I double checked and repaired it with techtools pro, no bad sectors.
    Reinstalled hdd in place and checked cables.
    I reseted PRAM, SMC, repartitioned and reformated the disk.
    It'll eventually show the same error the next boot when running disk utility.

    I made a 100 Gb bootcamp partition and installed windows 7, several apps and all the windows updates, and chkdsk doesn't report any error in the ntfs partition.
     
  5. rev.b thread starter macrumors regular

    rev.b

    Joined:
    May 1, 2009
    Location:
    Portugal
    #5
    Well, since nobody had any ideas about this, I'll tell you happened next.

    I did a clean system install, repartitioned and formatted the hdd with the install disk and the problem got away. Disk utility always report the disk as "OK".

    So I can only conclude that the problem was cloning the old hdd to this one with Carbon Copy Cloner, and I assume this was because this WD 750 Gb uses advanced drive format (4k clusters).

    As the scorpio black 750 Gb seems to be a favorite to upgrade MBP drives, if you run into troubles, try to do a clean install and do not clone the old hdd.
     
  6. bubbleboy450 macrumors newbie

    Joined:
    Dec 8, 2007
    #6
    This helps

    Thanks, this gives me some ideas about what might be going on. I have two 4k hard drives and a mbpro summer '10 edition and have had problems with both.

    I have an internal 2.5inch wd black 750gig drive that was giving me all these errors when I was first using it.

    I also have a 2tb usb drive with 4k sectors doing the same thing. The 750's problems went away by them self after a couple of formats.

    I realize now that the common denominator between all these problems was carbon copy cloner. I will format again and not use CCC this time to see if that is my issue.
     
  7. bombich macrumors newbie

    Joined:
    Dec 15, 2011
    #7
    Comments from the developer of Carbon Copy Cloner

    I realize that this is an older thread, but in case anyone stumbles upon it via Google, I wanted to make a few comments:

    1. CCC can not cause filesystem corruption. This is the case for most applications in fact. Except for filesystem utility applications (Disk Warrior, Disk Utility, etc), applications can't make direct changes to filesystem entries. Instead, they use standard system calls to create files and folders and to modify their attributes. I call "mkdir(/path/to/folder, 0755)", for example, and somewhere deep within the filesystem, a new filesystem entry is created by the OS. If I specify invalid parameters when creating or modifying a file/folder's attributes, the system rejects the change and returns an error. With this layer of abstraction between the applications and the filesystem, the OS and filesystem drivers prevent applications from corrupting the filesystem.

    Additionally, CCC can't propagate filesystem problems from one disk to another in file-copy mode. Some types of filesystem corruption can be "preserved" with a block-level copy, unfortunately I can't tell if that is what happened here. I don't think it is the case though, I suspect you were using a file-level copy for this particular task.

    2. I think the 4K/512b sector size difference is a red herring. I have run numerous tests between hard drives with different sector sizes (specifically this combination) and concluded that sector size differences have no effect on CCC's ability to accurately clone one volume to another (file-level or block-level copies).

    3. Filesystem repair is never straightforward. Sometimes the process of repairing a filesystem problem will uncover additional filesystem problems. If Disk Utility finds and repairs a filesystem problem, run the repair again until it comes up clean. I have seen cases where three consecutive runs all produce (and repair) different errors. In cases like that, I generally expect that some amount of data has been lost due to the filesystem corruption, and I prefer to resort to reformatting the disk and restoring the files from a backup. I have also seen cases where Disk Utility reported that it repaired a problem, but the same problem was reported on a subsequent run. Sometimes filesystem problems are due to issues outside of the filesystem (e.g. invalid information in the partition table), and these issues are best resolved by repartitioning+reformatting the volume. Some filesystem problems can't be "repaired", sometimes the solution is to start with a fresh filesystem.

    4. Please don't hesitate to contact me with concerns about Carbon Copy Cloner. I can't patrol the Internet and respond to every forum post out there, but I do respond to every support request submitted to my Help Desk. Drop me a note at help.bombich.com and I'm happy to offer expert advice in situations like this.

    So what happened in this case? I think you may have had invalid information in your partition table that was leading to the "Invalid volume * count" errors (e.g. perhaps the size of the volume was incorrectly recorded in the partition table, or was no longer accurate due to the sparing/remapping of failed sectors [note that failed-but-spared sectors are ignored by sector-scanning utilities]). Repartitioning the disk is exactly what I would have suggested if these errors recurred after simply reformatting the volume. I think that a subsequent restore with CCC of your older volume to a new volume on a freshly partitioned disk would have worked fine.

    Mike Bombich
    Bombich Software
    http://www.bombich.com
     
  8. bubbleboy450 macrumors newbie

    Joined:
    Dec 8, 2007
    #8
    Carbon Copy Cloner

    Thanks so much for taking the time to post all that information.
    I have since resorted to formatting my drive and copying the data manually.

    While I see your point, that the fact that carbon copy cloner was the one corrupting my data was most likely a fallacy through coincidence. I am still skeptical, but believe your statement that there must have already been a corrupted partition table to be the most likely.

    In any case, migrating my data manually after a format has completely resolved the issue that I was having (after a fresh format of course).

    I will try carbon copy cloner again soon, since I like it so much.
     

Share This Page