Problems with my iPhone native apps crashes and more

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fishmoose, Nov 16, 2008.

  1. fishmoose macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #1
    Hi!

    Lately i've been having some serious problems with my iPhone 3G (16 gig if that matters)

    The thing that first happend was that i was listening to music and browsing the web on my iPhone and safari startes to lag really really bad so i try to quiet it but it wont work then the music started to "lag" so i tried to turn the volume down and it wouldn't work. The phone wasn't responding at all.

    When i finally got control again safari crashed to springboard but the music was still playing and it now had done my command of turning the volume down and i tried to turn it up again but then it went to the highest volume!
    I have in-ear headphones so you can imagine how that felt, anyway i ripped the headphones out of my ears and turned the phone off and everything seemed normal.

    When the phone had rebooted i went to safari settings and safari had crashed so much lately so i figured i should delete everything, cache, history,cookies and databases.

    Everything went fine until i've tried to delete my databases i had two the first one i cant remember what it was but the second one was something to do with gmail and i do quiete often log into gmail on my iphone using safari.

    So when i tried to delete the gmail database the settings meny crashed to springboard! So i thought that was strange, then my phone worked fine for a day then some really strange things started happening.

    Safari started crashing 4-5 times per day for example, didn't really bothered me so much because everyone knows mobilesafari is buggy.

    But just now like 10 minutes ago i was browsing the app strore and that also crashed!

    Basically my phone has been really buggy lately, the screen also feels a little of. And i had almost zero issues before :(

    I have been really cautious with the phone, never dropped it, no water damage, haven't had it in any tight pockets and such.

    So what should i do?

    I'm guessing a restore might solve it? Or should i take it to Apple?

    Any help is appreciated

    And sorry for the long post but i really wanted to try to explain this really good.

    Anyway thanks for reading and please respond!
     
  2. iblastoff macrumors 6502

    Joined:
    Aug 2, 2008
    #2
    a restore might help for a little bit. lets admit it, fw 2.1/safari/the iphone in general is a buggy mess.
     
  3. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #3
    Yeah sure the iPhone os is buggy but i should have noticed it before, i've had it since August and this is the first time I'm really disappointed.

    I had used the iPhone everyday since I got it and i haven't noticed anything before.
     
  4. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
  5. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #5
    These issues wen't away after 2.2, but has now returned, what should I do about this?
     

Share This Page