Problems with MyWi OnDemand and iPhone 4S + iPad 2

Discussion in 'Jailbreaks and iOS Hacks' started by Dorkington, Jan 23, 2012.

  1. Dorkington, Jan 23, 2012
    Last edited: Feb 1, 2012

    Dorkington macrumors 6502a

    Joined:
    Apr 5, 2010
    #1
    Update: 2/1 - Devices no longer connect to each other. Have uninstalled, rebooted, cleared preferences. Nada.
     
  2. ThHeartlessHero macrumors member

    Joined:
    Jan 22, 2012
    #2
    MyWi worked perfect for me including OnDemand on iPhone 4S and iPad 2 both running 5.0.1. Do you have any other apps that may interfere with it? Did you go through the OnDemand setup on the iPhone and iPad?
     
  3. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #3
    I wouldn't know if I do or not, as there is no list of conflicts that I am aware of. I've kept my mods fairly light:

    FolderEnhancer
    SwitcherMod
    SBSettings
    RetinaPad
    FullForce

    Regarding the setup, I followed the instructions step by step.

    I'll possibly attempt again, but I've seen on Twitter that he posts that they need to update it for 5.0.1
     
  4. Jacquesass macrumors regular

    Joined:
    May 6, 2003
    #4
    I'm a big fan of TetherMe. It has worked flawlessly for me, both as a MiFi-esque hotspot for both my MBP and the iPad2, as well as USB-tethering for the MBP. USB-tethering is really fantastic in an airport where a) you can also recharge your iPhone while only using one power outlet and b) there are many WiFi networks jamming the spectrum (and you never know who else is lurking about).

    Did I mention that it was cheaper than MyWi? And that TetherMe users don't seem to be getting dinged by their provider because it uses the iOS native tethering profile?
     
  5. ECUpirate44 macrumors 603

    ECUpirate44

    Joined:
    Mar 22, 2010
    Location:
    NC
    #5
    Mywi has worked flawlessly for me for years. "don't install mywi" because of your isolated issue is pretty silly.
     
  6. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #6
    MyWi on-demand disabled my bluetooth as well. After some tinkering and a couple of reboots, it was fine. I disabled on-demand and MyWi app works just fine. I'm thinking there is a little bug that doesn't affect everyone.
     
  7. macbookman83 macrumors 6502

    Joined:
    Jan 23, 2011
    Location:
    New York
    #7
    I havn't had any issues with Mywi but I keep hearing alot of good things about TetherMe......


    For $5 bucks I think I may purchase.......... Wish I knew about it before I dropped the $20 a few months ago on MyWi.
     
  8. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #8
    As another poster has shown, it's not an isolated incident.

    I, as well, have MyWi for a while (bought a new license for my new devices even) with relatively few issues, but I thought bluetooth capability loss was a pretty big issue and warranted warning.

    A mod can feel free to change the thread title to something more appropriate if necessary.

    My apologies for any offense I have brought to you.

    ----------

    It appears they have updated the application, I have installed MyWi again and will test tomorrow with a new report. :)
     
  9. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #9
    I've installed the update on both devices and am successfully using OnDemand with no bluetooth issues.

    This can be marked as resolved. :cool:
     
  10. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #10
    Bluetooth disabled again briefly this morning, a reboot of the iPad cleared everything. Seems like the bug is still there, but less annoyingly at least.
     
  11. Mr. Zarniwoop macrumors demi-god

    Mr. Zarniwoop

    Joined:
    Jun 9, 2005
    #11
    What update is that? I have the same problem, and equally irritated over it. Bluetooth is completely borked up, and the OnDemand stuff doesn't work at all. I wrote Intelliborn and received a response that it's a known issue with iOS 5.0.

    I'm running MyWi 5.05.4 and MyWi OnDemand 4.50.6.
     
  12. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #12
    Strange... I was running a version lower than 5.05.4, but it appears 5.05.4 was released on the 21st. :confused:

    Either way, I reinstalled everything and it's going better. Though I do lose bluetooth functionality from time to time, and a reboot or two usually clears it up.

    More updates are needed, obviously.
     
  13. Dorkington thread starter macrumors 6502a

    Joined:
    Apr 5, 2010
    #13
    Well, that didn't last long.

    The two will no longer connect to each other via Bluetooth. Things I have done to resolve the issue:

    - Reboot
    - Uninstall/Reinstall
    - Clear preferences
    - "Forget this device"

    Nothing seems to fix it. All it does is sit on "Connecting" on the iPad 2, and nothing pops up on either to pair the two.

    :(
     
  14. scottycs macrumors newbie

    Joined:
    Aug 6, 2010
    #14
    i have the exact same issue! Just sent Intelliborn an e-mail.


     
  15. uncleapple macrumors newbie

    Joined:
    Feb 2, 2012
    #15
    Still waiting

    I sent this problem to intelliborn more than a month ago and received a reply that the onDemand connection problem was a known issue and that an update was in the works. As of today, still nothing.

    At least the hotspot option works, but that is not why I purchased onDemand.
     
  16. Jus711 macrumors member

    Joined:
    Jul 12, 2011
    #16
    Try changing the DHCP network address under advanced Bluetooth settings, that has worked for me in the past. Also, click "forget this device" in the Settings menu for each device. OnDemand has never worked correctly for me even going back to the 4.3 firmware. I just uninstalled MyWi altogether on the iPad, and just connect using Bluetooth to tether on the iPhone.
     
  17. scottycs macrumors newbie

    Joined:
    Aug 6, 2010
    #17
    Their response......

    Hi Chris,

    There is currently an issue with the OnDemand option if one of the devices is at ios5+. It will be fixed with an update soon. The WiFi connection should work.

    There will be a small number on the Cydia icon when the update is available. You can then open Cydia, changes, and see if the app listed is MyWi/OnDemand.

    I do not have a clear estimate on timeframe, but the developers are working tirelessly. Please keep checking Cydia for the latest updates available.

    I apologize for the inconvenience.

    Thank you for your interest in Intelliborn,

    Stephanie C.
    ----------------------------
    Intelliborn Support
    support@intelliborn.com
     
  18. uncleapple macrumors newbie

    Joined:
    Feb 2, 2012
    #18
    Thanks for the info Steph,
    I check Cydia several times a day just hoping.....,but nada. Maybe today is the day.

    In the meantime, I tried the DHCP change and no joy. I've rebooted and forgotten devices so mant times that I can't remember and no joy.

    I'm not sure how, but I did get the iPhone 4s to accept an incoming iPad2 onDemand request one time and the connection briefly worked but would not reconnect. The connection request and connection was listed on the iPhone as the iPad2's MAC address though instead of the device name if that helps any. No joy since. Maybe it was just a blind squirrel finding an acorn, but at least there's hope.
     
  19. macse30 macrumors regular

    macse30

    Joined:
    Jul 30, 2009
    #19
    Problems here as well. 4S/2 Bluetooth OnDemand fubar.
     
  20. cezarguerra macrumors newbie

    Joined:
    Feb 14, 2012
    #20
    Same problem

    O cant connect my iPhone 4s and my iPad either. I think the problem isn't in the mywi, but in the iPhone system that can't allow the Bluetooth connection from the iPhone and the iPad. I had the same problem in 2 iPhone's - one 4 and other 4S. When you change the iPad to host and the iPhone to client it connects, but the tether doesnt works. I tried estou remove, reinstall, forget device and, believe, format the iPhone and NOTHING works. :(
     
  21. ramirobryan macrumors newbie

    Joined:
    Feb 15, 2012
  22. ephewe macrumors newbie

    Joined:
    Feb 24, 2009
    #22
    Same OnDemand issues here

    Ever since I got my 5.0.1 iPhone 4 & iPad 2 both jailbroken, OnDemand has not worked. Oddly, one day I was able to get them to connect once after messing with it for hours and I thoughtI had it licked, but I have not a single successful connection since then. For now I'm using the wifi hotspot when I absolutely need a connection, but the whole reason I bought this software was the Bluetooth OnDemand (wifi is not a valid long-term substitute).

    I'd love to know what the delay is in getting this fixed. I mean, how long has it been since 5.0.1 on the iPad 2 has been jailbroken? A month? Two months..?

    Come on guys! OnDemand is your product's main selling point (when it works, it's a stellar product), and your license fees are nowhere near the cheapest option. A lot of us are (and have been) quite patient but how long are we expected to keep it up already..?

    Please, please, please, fix OnDemand!
     
  23. heyyitzmelissa macrumors 6502

    Joined:
    Jan 17, 2012
  24. ephewe macrumors newbie

    Joined:
    Feb 24, 2009
    #24
    Yep. Still doesn't work.

    If I didn't know better, I'd think the developer knows and just doesn't give a ****. I mean, he already got our money, right?

    *cough cough*

    I'm usually damn patient with this sort of thing, but I've lost count on how long it's been. This sort of thing is completely unacceptable. I will never be buying another thing from this developer and I'm going to make it my career to dissuade everyone I know from making the same mistake. That's about all I/we can do.

    Shoulda went with a competing program.
     
  25. BlueRaider macrumors regular

    Joined:
    Mar 2, 2012
    #25
    MyWi has been horribly buggy since the release of MyWi on Demand and iOS 4.3. I remember using it back in 2008 with my iPhone 3G and it worked wonderfully. It seems to get worse and worse with every update. I finally just gave up and started using Tetherme on my iPhone 4. I found the auto-connect bluetooth tethering to be spotty at best with MyWi and all the notification sounds I would get when my iPad and iPhone hooked up drove me crazy. Just download Tetherme and manually connect via Wifi or Bluetooth, it takes a second longer but too me it far less painful!
     

Share This Page