Problems with NetFlix instant streaming (reached device limit on ONE device)

Discussion in 'Mac Apps and Mac App Store' started by iconoclastic, Dec 27, 2008.

  1. iconoclastic macrumors newbie

    Joined:
    Dec 27, 2008
    Location:
    San Diego, CA
    #1
    The first time I loaded up NetFlix instant streaming it worked great.
    Now its saying I have reached the limit of devices that can connect to the service. The thing is, I have only used my one Macbook Pro to connect.
    Under attached devices in Netflix its showing me as having multiple mac's with different serial numbers attached. Now its not even letting me deactivate any of the currently activated devices.

    So I guess my question is, is there a reason why their server would recognize my computer as having different serial numbers? Has anyone else had this problem and know of a way to fix it?:confused:

    Aside from having to call up netflix and talk with them about it, of course.
     
  2. caggc macrumors newbie

    Joined:
    Jan 3, 2009
    #2
    Same Here

    I too am having this problem with my MacBook that I just got. Have you figured out how to fix it?
     
  3. caggc macrumors newbie

    Joined:
    Jan 3, 2009
    #3
    Update

    I went into my netflix account and deactivated the 6 mac "computers." It then worked fine. I guess I'll have to do that every time. Still would like an explanation but at least it works now.
     

Share This Page