Problems with permissions 10.5.8

Discussion in 'macOS' started by naturefreak85, Aug 17, 2009.

  1. naturefreak85 macrumors newbie

    Joined:
    Aug 17, 2009
    #1
    Hi all, I currently have a bit of an issue, and I was wondering if you all had any solution that I haven't tried.

    I have an iMac 24 inch running 10.5.8 that randomly had it's permissions completely corrupted. On the main user account, there is no way to export photos to an external drive or the desktop. When trying to do so it states that you do not have the permissions to do such. From the main account, I have gone into the desktop information seen that there are extra permission accounts placed in, 2 blank ones, clearly a corruption. I did try to do a repair permissions from the account and it did not resolve the issue at all. I also did try to manually add in permissions to the Desktop and still no resolution. Is there any other solution besides an erase and install?
     
  2. kisuke3 macrumors newbie

    Joined:
    Feb 6, 2009
    #2
    Problems with permissions 10.5.8

    1. Try downloading the 10.5.8 combo update
    2. boot into safe mode and run the permissions there

    If this does not solve your issue

    3. boot to the OS X cd and do a repair disk and repair permission
    4. Also, you can select reset password from the utilities menu then press reset ACL. Here's how you're going to do it

    Once you've selected the language, you'll see the welcome screen just ignore it. On the top you'll see utilities. Select reset password. DONT RESET THE PASSWORD, on the bottom you'll see reset ACL
     

Share This Page