Problems with Personal Hotspot since update

Discussion in 'iOS 6' started by jkeep, Sep 21, 2012.

  1. jkeep macrumors member

    Joined:
    Jul 25, 2011
    #1
    Hi,

    Not sure where to post this so I thought I would try here.
    Ive been using my iPhone 4 as a personal hotspot connecting to my MacBook Pro for about six months without any problems until the other day when I updated my iPhone to iOS6.

    Since then I have had nothing but trouble connecting to my personal hotspot.
    The personal hotspot comes up straight away on my iPhone but when I try to connect to the wifi on my MacBook Pro it just keeps searching then shows my iPhone in the list of networks available but comes up with an exclamation mark on the Wi-Fi symbol and No Internet Connection.

    If I keep playing about with it, it will finally connect up and stay connected but if I switch off then go to connect up again I have the same trouble.

    I have updated my Mac book pro but this didn't help.

    Any help would be appreciated.

    Regards
    Jeff
     
  2. lordjonny macrumors regular

    lordjonny

    Joined:
    Sep 18, 2006
    #2
    I have the exact same problem, my gf's iphone 5 works perfectly though. Very annoying indeed. Not sure what the problem is.
     
  3. HMI macrumors 6502a

    HMI

    Joined:
    May 23, 2012
    #3
    Reset

    I haven't had the opportunity to use mobile hotspots like that much, but you may want to try resetting your network settings on your iPhone.

    General/Reset/Reset Network Settings to see if that helps.

    You might have to re-enter any personal wifi access point info again, but this might help when the iPhone creates the hotspot.

    On the MacBook Pro, you might want to delete the iPhone from your "preferred list," and re-add it back to the list with the new connection.

    If it was a "preferred network" before, it might be trying to connect with old "iOS 5" settings. Removing and Re-Adding it is the same as manually resetting the connection.

    This is all just speculation, as I don't know your setup, but it may prove helpful.

    Please share any other info that you feel may be important to fixing this.

    Good luck.
     
  4. Beelzbub macrumors regular

    Joined:
    Feb 6, 2012
    #4
    This happen to me once. I restarted the phone and all was well.
     
  5. jkeep thread starter macrumors member

    Joined:
    Jul 25, 2011
    #5
    Worked a treat :) Many Thanks
     
  6. tonnyvd macrumors newbie

    Joined:
    Mar 18, 2012
    #6
    I have the same problem on both my iphone 4S and Ipad 3rd gen running iOs6. In the past I could use personal hotspot on both devices without any issues.

    Since upgrading to iOS6 I cannot establish a connection to either device when personal hotspot is enabled. Each time if I restart the device then it works again and will reconnect that same day. The following day I have the same problem and personal hotspot won't work properly without a restart. This is very annoying. I sync and back up my iPhone every night when it's plugged in and I assume that some network settings are being reset each time which is causing the problem to re-occur.
     
  7. NedFlanders macrumors member

    NedFlanders

    Joined:
    Nov 6, 2011
    #7
    I have been having the same problem. It always starts working after I reset the phone but sort of a PITA. I just tried the network reset as mentioned above but I will not know if it worked until tomorrow morning.
     
  8. Beelzbub macrumors regular

    Joined:
    Feb 6, 2012
    #8
    I ran into this again today too. Originally I mentioned restarting my phone did the trick, but now I am running into this all the time, and it is starting to be a pain. Although it is worth mentioning that when this problem happens, connecting via Bluetooth to the phone works fine. Which is what I did today because I was talking on my phone while using it as a hotspot and restarting the phone was not an option at the time.
     
  9. NedFlanders macrumors member

    NedFlanders

    Joined:
    Nov 6, 2011
    #9
    Well I have been in meetings all day so I just got a chance to test my hotspot after the reset. Unfortunately the problem is still there.

    I have an appt at the Apple store in 20 minutes to swap out a defective Apple TV so I am going to ask about this at the same time.
     
  10. Manuel Ramos macrumors newbie

    Joined:
    Dec 10, 2012
    #10
    Same Problem !

    Same problem... after update the IOS version the Hotspot setoped working working...
    Now,
    Some times the PC don't see the iPhone Hotspot...
    Some times the PC connects to the Hotspot but doesnt reach the net on the PC at the connections I have a yellow exclamation mark.

    Hellllllllppppp I do need my Hotspot... :(
     

Share This Page