Problems with Roxio popcorn

Discussion in 'Mac Basics and Help' started by skippy64, Jan 24, 2006.

  1. skippy64 macrumors member

    Jan 10, 2006
    North West England
    I purchased Roxio Popcorn last year and at the time tried to register it online but their site basically hung on the page when clicked on the submit button. Tried it a couple of times and basically gave up and forgot all about it. At that point I was on 10.3.9 and Popcorn has run fine. Now my problem is I have just bought and gone onto 10.4 and now Popcorn won't work at all. It launches OK but when I go to choose disc image it then quits. Obviously I thought go to downloads at Roxio and get latest update. This is where my problem now is, I need to register to get to the downloads !!!!, and lo and behold the registration still doesn't work, same problem as before. Has anyone experienced the same, or have any suggestions or links to anywhere that will have the correct updates I need for Popcorn to work again ?
  2. AtlJohn1980 macrumors newbie

    Feb 4, 2006
    Atlanta, GA
    I'm having the same problem, I'm using Popcorn 1.0 worked fine on Power PC but on the Intel it does the same thing, it willl open, try to drop a Video_TS folder and boom it shuts automatically, even with the update, it still won't work to Popcorn 1.0.2. Anyone have ANY idea about whats going on????????????

Share This Page