problems with signing - at wits end

Discussion in 'iOS Programming' started by benuk, Aug 14, 2008.

  1. benuk macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Hi,

    Having big problems signing.

    Have followed instructions, and created development and distribution certificates, appid, deviceid and dev and dist provisioning profiles. Installed all certs (including apple one) into keychain, all appear valid.

    When signing get the following error from xcode :-

    CodeSign /Users/benholland/Documents/MIST/build/Dist-iphoneos/MIST.app
    cd /Users/benholland/Documents/MIST
    /usr/bin/codesign -f -s "iPhone Distribution: Ben Holland" --resource-rules=/Users/benholland/Documents/MIST/build/Dist-iphoneos/MIST.app/ResourceRules.plist --entitlements /Users/benholland/Documents/MIST/build/MIST.build/Dist-iphoneos/MIST.build/MIST.xcent /Users/benholland/Documents/MIST/build/Dist-iphoneos/MIST.app
    /Users/benholland/Documents/MIST/build/Dist-iphoneos/MIST.app: CSSMERR_TP_NOT_TRUSTED

    Google does not return much except to regenerate all keys and certs which I have done 3 or 4 times with the same result.

    running command from terminal returns same result : CSSMERR_TP_NOT_TRUSTED

    anyone else have this problem? I am at my wits end with this stupid signing!

    thanks in advance
     
  2. benuk thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #2
    Still no further, however I have discovered what the error means.

    CSSMERR_TP_NOT_TRUSTED - The certificate could not be verified back to a root certificate.

    Would point to a keychain problem, despite the fact I have deleted and regenerated all keys and certs 3 or 4 times!
     
  3. benuk thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #3
    Solved by removing all keys and certs (again) and only generating distribution keys and certs.

    why it worked this time I have no idea.

    something to try if anyone else is having this issue
     

Share This Page