Problems with the Rebel Touch for the 2G

Discussion in 'iPod touch' started by Packersfan27, Dec 18, 2008.

  1. Packersfan27 macrumors 6502

    Joined:
    May 29, 2008
    #1
    Hi, I am having some weird problems with the Rebel Touch I just bought for my iPod Touch 2G. The volume and sleep/wake buttons are very unresponsive (especially the sleep/wake button). Has anyone had any problems with this case before like my problem?

    Thanks
     
  2. MaxPower49 macrumors 6502a

    Joined:
    Sep 11, 2008
    #2
    I haven't had that problem but I have read some others that have... Someone said if you use your fingernail and pull the case up a little bit where it covers the buttons, you might be able to fix it. You have to make sure the button cover is properly seated on the button.
     
  3. Packersfan27 thread starter macrumors 6502

    Joined:
    May 29, 2008
    #3
    I wiggled it around a bit and it now works most of the time. The button doesn't 'press' though, I just touch it it won't actually press down like my other case. Is this normal?

    I also email switcheasy because after making their tread I saw a notice about this issue and it said to email them for a replacement...

    Ill see how that turns out.

    edit: I got it to work 10 times in a row! And the volume buttons work awesome now! 10 minutes ago I was about to throw this case into my microwave lol. Sleep button still doesn't press though. I just touch pretty hard and it works.
     
  4. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #4
    Had that problem with the 1st gen iPhone's sleep button w/o a case on...SOOO annoying. Hope you get it fixed! :)
     
  5. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #5
    ok idk if this will fix it but it will prly help:

    1. take of the case
    2. put the case on with the sleep/wake in FIRST
    3. push the volume keys in next
    4. put the rest of the case on normally
     
  6. Packersfan27 thread starter macrumors 6502

    Joined:
    May 29, 2008
    #6
    I emailed switcheasy and they told me to push the sleep/take button on the case away from the screen as far as I could. I guess the button on the case wasn't on the actual button correctly.
     
  7. Kwats macrumors member

    Joined:
    Mar 26, 2008
    #7
    did the method you used work? usually you would get a replacement if you had that problem if you just contacted them than that would work. but otherwise use the fingernail trick like everyone else does or just play with the cases buttons a bit. so that will work. if not you could probably get a replacement.
     

Share This Page