Problems with Time Machine

Discussion in 'Mac Basics and Help' started by Dirtyharry50, Feb 8, 2013.

  1. Dirtyharry50 macrumors 68000


    May 17, 2012
    Roughly three weeks ago I began having problems with Time Machine not backing up on its own. Sometimes I would check it in the menu bar by pulling down the menu and it would display the last backup being done many hours earlier and no indication it was running or attempting to run. It seems to hang on "Preparing to backup" mostly. When it does this, if I try to reboot, the machine will not successfully reboot. I must power it off and turn it back on. Once I do, I can manually run Time Machine and it works fine. When Time Machine is hung up, other unfortunate behavior of the system occurs such as Parallels will not start until I reboot which does not work so I have to turn off the computer and restart it. Or Finder will crash if I try to look at the drive where the backups are (a Seagate USB drive). I noticed when I try to look, the icon next to the drive in Finder is spinning like something is happening but it just goes on forever.

    Stuff I have tried so far:

    Ejected the disk and removed it then plugged it back in. This did not help.

    Called Apple support who had me reset the PRAM, run disk utility on both the Macintosh HD and the backup HD (it found no problems) and finally, completely reinstall OS X (10.8.2). This did not work.

    Called Apple support again who had me repartition the drive and format it exclusively for Mac (with option to boot an OS X install if desired but there is ONLY the backups on the drive). This did not work.

    Ran Disk Utility and fixed permissions on the Macintosh HD. This did not help.

    Downloaded a utility from Seagate that checks the USB drive (it passed) and also turns off its power saving feature. It is turned off now. This did not help.

    Since the problem seems to always occur after my iMac has been asleep, I turned off the option for OS X to put hard disks to sleep. This did not help.

    Lastly, I tried turning off all power saving features on my iMac except for making the display sleep. THIS WORKS. Backups run every hour on the hour just fine. I tested for over 24 hours and it worked flawlessly.

    I forgot to mention that the system is a mid 2011 27" iMac i5 with 12 gigs ram and 1 TB HD. The Seagate drive is a 2 TB drive and is used ONLY for Time Machine.

    Everything was working fine for many months. I have no idea what changed so that it never works after sleep now. I always have to try and reboot, which always fails, then turn off the computer, turn it back on, then Time Machine works fine until the next time the computer sleeps. Once it wakes up, Time Machine is screwed again and seems unable to see the drive even though it is actually turned on.

    I've been tempted to try replacing the Seagate drive which was purchased when the iMac was but I'm not made of money by any means and I am confounded by the fact that the drive works just fine if I restart the iMac.

    Any ideas guys? I'd be grateful for any assistance with this problem.

    Oh, one last thing. I am not running any sort of utility software or any kind nor any anti-virus, etc. And I have tried leaving all apps I normally use (Safari, Things, EverNote, Mail) closed. It made no difference.
  2. NikMac macrumors member

    Feb 9, 2008
    That's very odd.

    I believe there is a free dashboard app you can download called "Time Machine Buddy" - it displays all the relevant log files produced by Time Machine during a backup. When I had a problem with the backup freezing at a certain point (see thread ) it helped identify what was causing the problem, maybe it will be useful to you.
  3. Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Thank you. I will take a look for that on App Store and maybe it will shed some light on this situation.
  4. Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Well, I did not find Time Machine Buddy on the App store but there was another app that does the same basic thing, displays the logs and highlights any error messages in red text. It is called "Logviewer for Time Machine" and was only 99 cents so I bought it and ran it to see what I might see.

    Unfortunately, when Time Machine dies as described above it does not log anything. The logs are always two lines (without errors) just indicating it is starting as normal. Then it stops logging at the same time it stops working.

    I would expect that if Time Machine encountered some issue accessing the USB drive it would return an error and log this. But no! So I remain in the dark, as does Apple support thus far, as to what is really going on here. :(
  5. coolmacoz macrumors newbie

    Apr 14, 2012
    Sydney, Australia
    The problem is probably reading from your computer. I would do a full backup of your computer to external HD by using other software (Carbon Copy Cloner, SuperDuper). Then bootup from external HD, and then erase the internal HD and reverse the process and restore system & data from external HD.
    As you do not know what the problem is, I would prefer to re-install a new system first, then migrate data from external HD.

    If too much work or don't have time to fix it, just try different software for backup rather than Time Machine.
  6. smirk macrumors 6502a


    Jul 18, 2002
    Orange County, CA
    My first thought was that something on your backup drive became corrupt, but you reformatted it and the problem persisted, so it can't be that.

    To get more information about what Time Machine is doing, you can run, select the log for "all messages" or "system" (I can't remember the exact wording, I'm not in front of a Mac), and then filter by "backupd" (without the quotes). This will show you all the Time Machine messages.

    If you can find the point in the log when the issue occurred, you can click on one of the log lines to select it, then clear the "backupd" filter to reveal all messages again. Your point in time in the log will still be selected, so then you can take a look at the messages from other processes around the same time to see if anything seems "funny". Maybe USB errors or some sort of disk error.

    Good luck, let us know if you find anything!
  7. Dirtyharry50, Feb 12, 2013
    Last edited: Feb 12, 2013

    Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Thank you very much for telling me about Console. I didn't think to go looking at the utilities that come with a Mac. I found a mixed bag of clues poring through the system log. Most interestingly, on some but not all occasions where backup failed, there was a series of four function calls on the drive object which each in turn timed out then the attempts stopped. It wasn't quite clear from the naming what the function call was attempting to do but I am guessing it involved waking the drive from sleep. Of course, with all power saving turned off the drive should not have been asleep to begin with and I was not attendant at the time so I can't know for sure if it was. Just the same, this appears to be what happened in some cases.

    The fact that Time Machine melts down in this scenario, taking Finder with it is disconcerting and confusing. I would expect error handling for a case this common to be in place and to handle a failure to access the drive for any reason, be it power, disk failure, read or write failure, etc. I would also expect an error message to the user to indicate this failure, preferably including the nature of the problem encountered. But no!

    At one point, the drive appeared to be asleep when Time Machine was not scheduled to run and I noticed this. The drive light went off so I assumed it was asleep. I ran Seagate's own simple diagnostic test on it at this point and it failed. I ran it again and it failed. In fact, the test never seemed to begin. Normally a progress bar appears and it takes maybe two minutes to run. So I ejected the disk with Finder which worked. Then I unplugged it, waited a moment and plugged it back in. It was recognized and mounted in short order and visible in Finder. I ran the Seagate diagnostic again and it ran fine and passed the test. From this I am somewhat inclined to think the drive itself is flaky and erratic perhaps about sleeping when it isn't supposed to and reluctant to wake up when asked to. That is just guessing though.

    I ran that Seagate test again just now where I noticed the drive light was off. It ran just fine and passed. The light never flashed or came on. Perhaps the light does not indicate power status but just disk access. It doesn't flash at all, it just emits a steady glow, so who knows?

    I know I've just about had enough of this!

    I am going to run a test for the next 24 to 48 hours with power saving features on the way I normally had them since buying this computer and USB drive and see what happens. I expect it to fail at some point and then I will use console to take a look one more time. Beyond this little experiment I think it is time to call Apple Support again and suggest that an engineer qualified to review my system log do so and diagnose the problem. I need someone who understands exactly what those failing function calls are doing. That will probably explain what is going on here.
  8. smirk macrumors 6502a


    Jul 18, 2002
    Orange County, CA
    Sounds like a plan. I suspect that you'll find that the cause is a flaky external drive. If you have access to a friend's drive, maybe connect that instead and back up to it and see what happens. The fact that the Seagate tools failed at all indicates that something is wrong with the drive (or USB cable, or drive controller, etc... which is the same as saying that the drive is bad).

    You're welcome to post the log entries you found and maybe someone here can help interpret them, too.
  9. Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Twenty fours plus so far, with multiple periods of sleep including a long one overnight and Time Machine has been running flawlessly, every hour on the hour while the system is awake, including right after it has woken up.

    Good Lord. I wonder if this is going to be one of those curious problems where I somehow managed to fix it but have no idea what I did to actually solve the problem. I hope so!

    We shall see what the next 24 hours and beyond bring.

    Since I purchased an Apple router, I regret now that I did not purchase a Time Capsule. I may do that in the future at some point and pass on my router to my daughter.
  10. Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Time Machine still hasn't failed but now I've gotten the dreaded: "Disk not ejected properly!" error message when waking from sleep twice in the past day! Arghhhh!!!

    So, each time I unplug the USB cable right away and plug it back in. The drive mounts and all is well again. Until whatever goes wrong next I guess...

    I should have bought a Time Capsule.


    All of this revolves around the computer going to sleep and waking up.

    Maybe I should try plugging the USB drive into the back of my Airport Extreme and reconfiguring Time Machine to see it, etc. and see what happens in that case. I wonder if that would work.

    I am afraid to buy another regular USB drive after some Google searching and seeing how many people on Apple support forums have issues like mine with USB drives being problematic, ejecting themselves, failing to work with Time Machine, etc.
  11. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
  12. trbartholomew macrumors newbie

    Feb 17, 2013
    New External drive -- time machine keeps preparing for backup...

    So my girlfriend got a new desktop external drive. She has her old time machine backups on a separate external hard drive, which also contains her itunes and aperture libraries. She was wanting to backup these, as well as her old backups. She keeps the old external hard drive connected, but when I set up her new external drive (4 TB, more than enough to hold her old 750 GB worth of pictures, music, and backups), it gets stuck on preparing. It is formatted correctly, and I disabled her McAfee (which she is required to have at school), to make sure it wasn't interfering. I checked the console and couldn't find anything fishy (thought I have limited experience with it), except that it keeps thinking there isn't enough room on her old drive for a new backup, even though it starts by saying it is backing up to the new external drive (the Seagate, in this case). I've attached a screenshot of the console when I attempted to start the new time machine backup on the new drive. It stayed at preparing overnight...any suggestions? She is running 10.7.5, and I performed the supplemental update that seemed to be fixing some.

    Attached Files:

  13. Lightning Bolt macrumors member

    Feb 15, 2013
    Windy City Suburb
    Should I skip Time Machine?

    Just a quick question for all that use time machine (or did)...

    I'm not new to Mac's but am new to Time Machine.

    I was going to get a small 1TB portable drive and use TM for back-ups from my new MacBook Pro running 10.8.3

    After reading this (and other) threads about Time Machine issues, I'm wondering if I should skip using it and just back-up the old fashioned way (dragging folders from one drive to the other)?

    Speed shouldn't be an issue as I'll be using USB 3 and Thunderbolt (which are both supported on the portable drive).

    Not sure if it matters but my wife's 2006 Mac mini (running OS 10.4.11) is also on the mini network and I'm not sure if Time Machine would see that and cause yet more issues?

  14. smirk macrumors 6502a


    Jul 18, 2002
    Orange County, CA
    I've used Time Machine since Snow Leopard, at first on an external drive and then later on a Windows Home Server setup (at first kind of hacked and then later by using Netatalk). It has worked fairly well for me. There have been some hiccups along the way where the sparse bundle file that stores all the backups on the server got corrupt, and in each case it seemed tied to my Mac going to sleep in the middle of a backup. After sleeping, the Mac would wake up and try to continue where it left off, but of course the server was like "You left me hanging two hours ago, I already closed all those files". The result was that the many files that make up a sparse bundle were left in an inconsistent state. This is probably more info than you want, and probably doesn't affect you as my setup is really an unsupported one.

    I've never had a problem with Time Machine attached to a local disk. Time Machine works pretty well, but it's not perfect. In my opinion, it is better than manually dragging files across, which you'll forget to do from time to time. Also, with the manual approach you may start wanting to keep different versions of the same file, and then it's likely that you'll get confused down the road when you try to remember which manually-named version is the one you want to restore.

    I think Time Machine is the easiest and most convenient backup solution. There are lots of third party backup programs, some free, that will also work well and that will perform automated backups on a schedule. Since your backups are a duplicate of your data and not the sole copy, you could always start using Time Machine and then switch to something else if you're not happy with it, without really impacting anything.
  15. Lightning Bolt macrumors member

    Feb 15, 2013
    Windy City Suburb
    Thanks smirk!

    Question though... Seems like a lot of the problems arise when the Mac goes to sleep during (or preceding) a Time Machine back up. Since I'm using a Macbook now as my main computer, it will be going to sleep (by choice) much more often so that's my main concern.

    Is there a way to adjust Time Machine preferences so that it will ONLY back up when the Macbook is NOT sleeping?

    What are the time interval options?
  16. smirk macrumors 6502a


    Jul 18, 2002
    Orange County, CA
    Sadly, virtually nothing is configurable with Time Machine. It backs up every hour, automatically.

    I do know someone who never had any issues with their computer going to sleep interfering with Time Machine. He even ran some tests where he'd purposefully sleep the computer in the middle of a backup, and everything worked fine.

    When backing up to a physically connected hard drive, there's no sparse bundle involved -- files are just written directly to the drive. I would think that even if the computer slept in the middle of a backup, when it woke up it would just continue where it left off. Perhaps someone who backs up to local drives could weigh in on this.
  17. brent paul macrumors newbie

    Apr 9, 2013
    Time Machine backup failures

    Starting a couple of weeks ago, I started getting backup failures indicating there was not enough room on the disc to complete the latest backup. This had not been a problem in the past. My limited understanding makes me think Time Machine has stopped removing the oldest backup. And then again, I could be totally wrong. Help would be most appreciated.
  18. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    First just remember to use System Preferences->Time Machine, options and block Boot Camp partitions and mounted external drives.
  19. jcapune macrumors newbie

    Jan 2, 2012
    Can't Find My Problem Here...

    Time Machine backs up but every date is the same "January 5, 2013". Is it the drive or Time Machine" :confused:
  20. luisbedin, Apr 30, 2014
    Last edited: Apr 30, 2014

    luisbedin macrumors newbie

    Apr 30, 2014
    What I notice too, is that when my iMac is sleeping and I try to connect my iPhone to charge, it doesn't happen. So, I think the problem is when the Mac sleeps it turn the USB off and don't do any backup in the last hours, and when the Mac comes back, it has an error saying that don't exist any recent backup and stops of work properly. I don't know how to fix it, unless never let my Mac sleeps. If you could get an answer at the last year...
    Sorry about any english mistakes.
  21. Dirtyharry50 thread starter macrumors 68000


    May 17, 2012
    Well, my solution wound up being to replace the Seagate USB drive I was using with a Western Digital USB drive. It has worked perfectly ever since, more than a year now.
  22. qfactor macrumors newbie


    Mar 5, 2014
    Seagate 1tb Backup Plus Slim

    I ran my first Time Machine backup today. My MBP is only around five months old, so I only had about 100gb to back up.

    I kept getting errors saying that the "disk wasn't ejected properly", halfway through the backup. I restarted, shut down but the problem seemed to persist. Even more infuriatingly, the transfer seemed to be running at a speed of a few KBs at a time instead of hundreds of MBs over my USB3 connection.

    I then shut down and re-attached the HDD with my WD Passport's USB3 cable. This seemed to fix the problem and the update was completed in about 25 minutes (total time of around 55 minutes approximately, for a 100gb backup).

    I suspect the issue is with the standard cable Seagate issues with its hard disks. I'm going to switch back to the other cable and see if it creates any issues with the smaller incremental backups. Will let you guys know if it misbehaves.

Share This Page