Problems with UASP USB 3.0 disk enclosure

Discussion in 'Mac Accessories' started by djc6, Dec 18, 2014.

  1. djc6, Dec 18, 2014
    Last edited: Dec 18, 2014

    djc6 macrumors 6502

    Joined:
    Aug 11, 2007
    Location:
    Cleveland, OH
    #1
    I recently purchased a StarTech.com S3510BMU33B "USB 3.0 to 3.5" SATA III Upright HDD Enclosure With UASP". Inside I have a "Western Digital 2TB AV-GP SATA 3 Gb/s Intellipower 32 MB Cache AV Hard Drive" model WD20EVDS

    The problem I am having is this.. when I connect the enclosure to my Mid-2014 MacBook Pro 13" w/Retina display, the drives are immediately ejected upon mounting. I get the following kernel messages in the Console (there are three partitions on the drive):

    kernel: IOUSAttachedSCSI: device not responding, terminating.
    kernel: disk2s1: media is not present.
    kernel: disk2s2: media is not present.
    kernel: disk2s3: media is not present.
    kernel: hfs: err 6 reading VH blk (vol=Volume1)
    kernel: hfs: err 6 reading VH blk (vol=Volume2)
    kernel: hfs: err 6 reading VH blk (vol=Volume3)

    I've tried a couple scenarios to see what the problem is:

    Mid-2014 MacBook Pro is running 10.10.1 and Mid-2011 mac mini is running 10.8.5

    1) Mid-2011 mac mini (USB 2.0 capable) - works with included USB 3.0 cable and a spare USB 2.0 cable I had around.
    2) Mid-2014 MacBook Pro 13" - works when I use my spare USB 2.0 cable
    2) Mid-2014 MacBook Pro 13" - fails when I use 3.0 cable included with enclosure.

    StarTech.com thinks maybe its a problem with USB 3.0 cable, specifically one of the extra pins - since the cable works on my 2011 mac mini that is USB 2.0 only. I don't have any extras, they offered to send me one for free to test.

    Additionally, StarTech.com said they have problems with WD not spinning up fast enough. They had me do the following:

    1) Unplug USB cable
    2) Power down enclosure & wait 10 seconds
    3) Power up enclosure and wait 20 seconds for HDD to spin up
    4) Connect enclosure via USB.

    This worked with USB 3.0 cable... is this little dance normal?
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    USB dances are normal, the green or intellepower can be a PITA. But the enclosure firmware can also contribute to the frustration, especially how it deals with USB3 sleep states. USB 2 usually has little issue because it does not have the USB protocol complexity that enclosures and hubs sometimes don't have well sorted out. Sleep states and UASP being most notorious.

    Little help I know, my WD Elements and Seagate BU Plus work just fine, although they can be slow to spin up, where my HGST is just a pain regardless. I usually have to disconnect the enclosures power and then reconnect after the Mac or windose PC is operating
     

Share This Page