Problems with Updating Apps in iTunes

Discussion in 'iOS Apps' started by Surely, Oct 23, 2009.

  1. Surely Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #1
    I've been having this problem for a few days now. Here is what happens:

    1. I check for updates for my applications by clicking the "Check for updates" link at the bottom of my Applications tab in iTunes.
    2. It shows that I have 3 updates available.
    3. I click "Download All Free Updates", and the 1st message below appears.
    4. I click "Check For Available Downloads.." in the Store menu, and the 2nd message comes up.

    Anyone have any ideas? I was able to update one of the apps on my iPhone with no problem (the others aren't on my iPhone anymore, but I'm keeping them around in iTunes for possible future use). Usually when I do that, the next time I check for updates in iTunes, that update disappears. It isn't disappearing.

    On my iPhone, it shows that all of my Apps are up-to-date.

    I've already tried quitting iTunes, and signing out and back into my account.
     

    Attached Files:

  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
    Do you use NetBarrier on your MacBook ?

    If so, go to >Privacy > Data > Surf > Information Hiding and make sure that Hide my Apple ID... is not selected.

    If not, move along... nothing to see here! :p
     
  3. Surely thread starter Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #3
    No, I don't use NetBarrier.

    But thanks for trying to help! :)
     
  4. DamFu macrumors regular

    DamFu

    Joined:
    Jul 13, 2007
    #4
    Same thing is happening with me. It is not all the time though. Yesterday I could update fine but the previous couple of days I got the same error. I was able to update via my phone though and synch the updated apps back to my library.
     
  5. kamettananda macrumors newbie

    Joined:
    Sep 29, 2009
    #5
    OS: 10.6.1
    iTunes: 9.0.2
    Netbarrier X5: 10.5.5

    There was a problem downloading "XXXXXXXXXXX".
    An unknown error occurred (8003)
    Please check that the connection to the network is active and try again.

    Turn offed individual components of NetBarrier;
    1: Disabled Firewall
    -: No Change
    2: Disabled Filtering
    -: No Change
    3: Disabled Data Filter
    -: No Change
    4: Disabled Banner Filter
    -: No Change
    5: Disabled Cookie Filter
    -: BINGO!
    6: Re-enabled Cookie Filter and disabled Information Hiding
    -: Error Returned
    7: Disabled Cookie Filtering and switched other features on one by one and the download worked overtime.

    I'm yet to determine the correct URL to set in the Trusted Cookies Section, I've tried
    www.store.apple.com/au (and us)
    www.apple.com/
    So for now if I'm downloading form the iTunes store I just turn off the Cookie Filter


    Surely, I realise the error message you are receiving is not the same, but just check any firewall settings you may have, particularly relating too Cookies

    If these don't work try
    Troubleshooting applications purchased from the App Store
    http://support.apple.com/kb/TS1702

    The above article recommends de-authorizing your computer
    iTunes Menu: Store: De-Authorize Computer

    Shut Down (Not Restart)

    Start Computer (Hard Reset)

    Re-Authorize Computer

    "Well Known" TCP and UDP Ports Used By Apple Software Products
    http://support.apple.com/kb/TS1629

    KINDNESS: Love with its workbooks on.

    Mac Book Pro 5,2. 17":apple: iPhone 3G:apple:
     
  6. Surely thread starter Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #6
    This issue has finally been resolved.

    Yesterday, I finally got around to writing iTunes support about my problem. I've been busy.... has this really been going on since Oct? :eek:

    An iTunes customer support rep got back to me today.

    Here's what he did:
    Once he removed the corrupted downloads, I was able to update my apps normally again.
     

Share This Page