Problems with WD external drives

Discussion in 'Mac Pro' started by treehorn, Feb 17, 2008.

  1. treehorn macrumors 6502


    Aug 21, 2007
    I'm not sure if this is a MacPro or System 10.5.2 issue or something else, but...

    Got my new MacPro on Thursday. When I got it, I plugged in all my drives to figure out what gets daisy chained where until I get my PCI Sonnet Firewire card. All my drives worked great, no problems (1 Lacie, 1 G-Tech, 2 WD). I ejected the two WDs from the Finder window and unplugged them. Then proceeded to install and update all software (FCS, OSX 10.5.2, Photoshop CS2, etc). Aside from 10.5.2 everything I installed was in my old IMac.

    Since then, I haven't been able to get either of my WD drives to work. One won't even power up. The one that does power up won't mount and looking at it using Disc Utility shows the drive as existing, but all options to repair/access it are greyed out.

    I checked the WD website and there were a few MyBook updates for firmware, button manager, drive manager, none of which seem to have any effect.

    Is anybody else having this problem?
  2. rtrt, Feb 17, 2008
    Last edited: Aug 13, 2011
  3. treehorn thread starter macrumors 6502


    Aug 21, 2007
    Here's the newest (and weirdest) thing about this...neither work in any other computer either. Not on my IMac running leopard or my Powerbook running Tiger. When I try to fix the one My Book with DiscWarrior, it comes up but says it can't be fixed as it isn't a supported file system - it's coming up as MS/DOS-PC
  4. rtrt, Feb 17, 2008
    Last edited: Aug 13, 2011
  5. island macrumors 6502


    Feb 19, 2007
    Try them using the USB interface and see if that makes a difference, if not try another firewire cord.
  6. treehorn thread starter macrumors 6502


    Aug 21, 2007
    I've tried connecting them via firewire and usb directly and daisy chained. And have swapped out cords left and right (ones that work with other drives have no effect)

    it gets even stranger...while DiscWarrior wouldn't let fix it, checking it seemed to made it mountable again, so I can at least copy everything to another disc, then re-format it, and see if it works.

    What I find odd is that both WD drives spazzed out at the exact time (and one hasn't Time Machine, fortunately, since I can just copy everything from my old computer again)
  7. BeyondMountains macrumors 6502

    Jan 11, 2008
    both of my wd drives work fine. 1tb and 750gb with 10.5.2. I just plug them in and there they are, ready to go.
  8. ErikAndre macrumors 6502a


    Nov 14, 2007
    One of my FW400 500GB (WD MyBook) drives went corrupt. It was my FCP Scratch Disk for a massive project I was working on, only 7 months old. I didn't discover it was corrupt until I received my MacPro and attempted to pull all the data from it to move to my new internal scratch disk. I since had to purchase Data Rescue II and am in the process of pulling data off it.

    Blasted WD. :mad:
  9. harish69 macrumors newbie

    Jun 14, 2012
    Macbook air external card disk

    Hi every one,
    i have WD external hard disk 1TB, and its not connecting with mac air.
    can any one suggest me that i need to install new drives or update hard s/w.
    Thanking you.
  10. macuser453787 macrumors 6502a

    May 19, 2012
    Galatians 3:13-14
    No worries - DR should get it done in fine style. :)

    Although if you have it (or are willing to purchase it), DiskWarrior should work marvelously and restore the file directory, which should render your WD drive usable and therefore enable you to copy the files onto another drive.

    If you decide to try that, maybe let DR finish first and then run DW. That way if DW doesn't help for whatever reason, you still have your DR-recovered files.
  11. dbit macrumors regular

    May 2, 2006
    I've had nothing but problems with WD drives, especially with Mac USB3 -> USB2 step down. WD uses really cheap enclosures and I/O controller boards. My last one exhibited the types of symptoms you described. Eventually I broke it out of the enclosure and found that the controller board had heat damage. Furthermore it had unusual thermal pads applied, meaning the board had shown problems in testing and had this patch applied to mke it salable. I've since put the drive in a new enclosure and reformatted and it works like a charm. WD takes a $90 drive, puts it in a $10 enclosure, and sells it for $180. I won't be buying any WD externals in the near future.
  12. derbothaus macrumors 601


    Jul 17, 2010
    WD is not any worse than LaCie. The #1 POS enclosures in the world. I have had 10+ die on me over the years. WD on 2 died. Seagate 3 dies. WD has the best track record so far. They also make the best HDD performance wise.
  13. dbit macrumors regular

    May 2, 2006
    To be fair all the retail consumer grade external's enclosures just suck. I think for 3.5's I'll probably put together my own from now on.

Share This Page