Problems with WI-FI? Brand new MacBook Air 13.

Discussion in 'MacBook Air' started by gguerini, Apr 4, 2012.

  1. gguerini macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #1
    I just got a brand new MacBook Air 13' and I believe I'm having problems with my WI-FI connection. Every few minutes, when I try to open a website it keeps loading for minutes and I end up with a time out message or that it couldn't find the DNS server. I just tried to open the same page on a PC in my network and it opened the page instantly. I pinged the IP address and it gives me a hight time.. around 60/70 ms. I personally think there is something wrong.

    Have you guys have problems like this?

    Thanks
     
  2. Oli3000 macrumors regular

    Joined:
    Apr 20, 2009
    #2
    Wirelessly posted

    My advice would be to restore it, if that doesn't fix it take it back within your 14 day window and grab a new one!
     
  3. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #3
    Have you tried changing your DNS settings on your router settings page? I had this problem and changed to Google's DNS, it's mostly quite good.

    8.8.8.8
    8.8.4.4

    It could be a conflicting DNS address in your Air's wifi settings, also.

    I also noticed that the Air wasn't great if I had security on my router, so I've set up an access list rather than having a password-protected network.
     
  4. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #4
  5. LadyX macrumors 68020

    LadyX

    Joined:
    Mar 4, 2012
    #5
    I was experiencing the exact same issue when I first got my 11" MBA. I kept getting connection timed out every once in a while, it was so frustrating! I went back to the store and the salesman connected my MBA with their Wi-Fi and the Internet was working perfectly so the problem was with my router. I went back home and updated my router's firmware and there was also an update for the AirPort utility. I updated both and I never faced this issue again.

    Like the above poster stated. Try not to password protect your router. My MBA suddenly loses connection with the router forcing me to turn it off and back on. Removing the security seemed to have solved the problem.
     

Share This Page