Problems with wifi

Discussion in 'OS X Mavericks (10.9)' started by Arashdn, Sep 11, 2014.

  1. Arashdn macrumors newbie

    Joined:
    Sep 11, 2014
    #1
    Hi,

    Sorry for my poor English.

    I have been facing many problems on connection to wifi with my MacBook Pro Retina (mid 2012)

    I'm using mavericks and updated to 10.9.4.

    My wifi is working well when I am outside of home , but when I am at home wifi list will not display anything.

    Even my iPhone wifi hotspot is not being displayed at home , but out side of home it's ok!!!

    When I select join other network , after entering wifi name and password sometimes it can connect , and some times I need to reboot my Mac to connect.

    I also installed Windows 7 using bootcamp , And every thing was working very well in windows (both at home and outside).


    for Solving problem I tried removing wifi Preferences files , create a new location , clean re-installing OS

    but none of them worked.


    What should I do?


    Thanks
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Do your Macbook connect any USB 3.0 devices when you at home?
     
  3. Arashdn, Sep 12, 2014
    Last edited: Sep 12, 2014

    Arashdn thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #3
    Usually not.
    I just some times connect my external Hard disk but not always(I also use my external disk outside).
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    If you create and log into a new user account does the problem still exist?
     
  5. Arashdn thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #5
    even re-installing OS did not fix anything
     
  6. Ray2 macrumors 6502a

    Joined:
    Jul 8, 2014
    #6
    You might try changing the channel on your router if its set to 13. I recently had a problem with my wife's Mavericks MBA when we moved over to our European home. I could not get it to work even when changing the language to German. I finally just put the router on another channel and it all worked. USA based routers do not use 13. Perhaps your Mavericks install is stuck in the USA. I believe mine was.
     
  7. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #7
    Clean reinstall and fresh user account...right?
     
  8. Arashdn thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #8
    Well , I'll try that.
    there are four wifi router around me when I am at home , but none of them is listed.
    Also my phone hotspot is not listed when I am at home :(
    Sure , Clean install and new user (also formatted whole disk)
     

Share This Page