Problems with YouTube videos

Discussion in 'MacBook' started by Ytsephill, May 4, 2013.

  1. Ytsephill macrumors newbie

    Joined:
    Sep 15, 2010
    #1
    Hey guys,

    I own a Late 2008 Macbook with the following specs:
    - 2.4 GHZ dual core
    - 4 GB 1067 MHz DDR3
    - NVIDIA Geforce 9600M GT 256MB
    - OSX 10.8.3

    So I've been having this problem that I hope someone can help me with.
    Every single youtube video I watch, "freezes" or "breaks" (don't know what the word is here) for less than a second and it happens for every minute or so of the video. It's becoming quite the annoyance, to the point I cant properly watch a video. The audio will run fine, it's just the video that stops and continues, stops and continues...

    My internet connection is very good so I can't say it's a problem with that. I've tried quitting all applications but that won't do.

    Does anybody got an idea where this problem might be coming from?
    Thank you
     
  2. Ann P macrumors 68020

    Joined:
    Jun 29, 2009
    Location:
    California
    #2
    Sounds similar to an issue I've had in the past. Is your Adobe Flash Player up to date? If so, perhaps try re-installing?
     
  3. Ytsephill thread starter macrumors newbie

    Joined:
    Sep 15, 2010
    #3
    I use Google Chrome as my web browser. From what I'm reading on a website on how to check if my flash is up to date:

    "In Chrome, Flash Player will automatically be updated to the latest Google Chrome version, so you can rest assured the version you have is the latest."
     

Share This Page