.profile

Discussion in 'OS X Mountain Lion (10.8)' started by Wnt2bsleepin, Nov 7, 2012.

  1. Wnt2bsleepin macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    Hello,

    I modified my .profile file to allow for easier access to Sublime Text 2. Unfortunately, the command does not work unless I reload my .profile every time with

    Code:
    . ./.profile echo $PATH
    I was wondering if there is anything wrong with my .profile file. Thank you for any help.

    Code:
    # MacPorts Installer addition on 2012-09-17_at_22:03:16: adding an appropriate PATH variable for use with MacPorts.
    export PATH=/opt/local/bin:/opt/local/sbin:/Users/Bryan/bin/subl/:$PATH
    # Finished adapting your PATH environment variable for use with MacPorts.
     
  2. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #2
    Add the line
    Code:
    source ~/.profile
    to the file ".bash_profile" in your home directory. The bash_profile is loaded each time you load a terminal window and by default the generic profile file is not. This will make the bash_profile load the generic profile.

    I put generic bash settings I like to transfer between computers in the ".bash_profile" file, and machine specific settings in the ".profile" file.
     

Share This Page