Program will not run in VM

Discussion in 'Mac Apps and Mac App Store' started by propower, Apr 7, 2017.

  1. propower macrumors 6502a

    Joined:
    Jul 23, 2010
    #1
    I have been using VMWare Fusion for many years - now V8 (not pro). I now have a Crown XTI amplifier that has a control App that is windows only. I installed it on my Wifes Win10 5 uear old laptop works fine. I have tried it in both a MacPro and a 2016 macbook pro with Fusion 8.5 and Win 10 (8.1 too). Program can not find the amp on USB. Went direct connect straight from amp to machine and everything. Not only does the program not discover the amplifier but it hangs on close everytime. USB discovery takes less than 15 seconds on the real windows laptop. I tried installing the VMWare tools and still no go. Every other Windows program works but not this.

    So - is that just the way it goes? Some things will NOT work on VMs??

    Any help appreciated
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    If an app expects to access hardware directly, then a virtual machine may not work, and from sounds of what you're writing that may very well be the case.
     
  3. cobracnvt macrumors member

    cobracnvt

    Joined:
    Apr 6, 2017
    #3
    When you plug in the Amp via USB to your Mac, do you get a pop-up Window on you Mac from Fusion that asks whether you want to connect the USB device to your Mac or the VM?
     
  4. propower thread starter macrumors 6502a

    Joined:
    Jul 23, 2010
    #4
    I tried Parallels instead and it was able to see the Device and connect. I spent 1Hr+ on the phone with VMWare Tech Support and they couldn't figure it out. I decided to just switch to parallels.
     

Share This Page