Programs not installing? Or maybe I'm not doing it right.

Discussion in 'Mac Basics and Help' started by TaterToT, Sep 23, 2009.

  1. TaterToT macrumors 6502

    Joined:
    Sep 16, 2009
    Location:
    OK
    #1
    Ok so I've tried to install Skype and Limewire but nothing happens, maybe I'm not doing something right. I see that a program called Installer shows up in the dock but when I click it nothing opens, and when I double click the download for the program nothing happens. Help please?

    Edit: Alright I restarted the computer and now everything works perfect. Thanks for the help.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Are you sure you've downloaded Mac versions, not PC? Go to Finder -> User -> Downloads and double click the download, it should mount to desktop and start installation
     
  3. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
  4. TaterToT thread starter macrumors 6502

    Joined:
    Sep 16, 2009
    Location:
    OK
    #4
    Yup I am downloading the mac versions, I see the icon on the desktop and I guess it tries to install but for some reason it's not working.
     
  5. TaterToT thread starter macrumors 6502

    Joined:
    Sep 16, 2009
    Location:
    OK
    #5
    Ok I think I installed skype right, I dragged it into the applications folder and it said installing and now it's in there.. but when I try to open it, it just bounces up and down but doesn't do anything and I have to force quit it.
     

Share This Page