Programs will not start up

Discussion in 'Mac Basics and Help' started by LexieMSU08, Apr 20, 2012.

  1. LexieMSU08 macrumors newbie

    Joined:
    Apr 11, 2008
    Location:
    East Lansing
    #1
    Hello -

    I am running on a 2008 Mac Pro, running Snow Leopard. Lately I've been putting my computer to sleep to save power. However, when it "wakes up", I can use already running programs, but I cannot launch any new ones. For example, I just tried to open "About this Mac" and it bounced a few times in the app bar, but then just stopped and the action disappeared, and the program never launched. I have Firefox and itunes open all the time (before/after sleep) so those are currently working without an issue. However, If I try to run any other program, Microsoft Word, BBedit, and so on.. They bounce a couple times then disappear. :confused:

    The problem goes away entirely when I re-start. But this makes my sleep mode completely useless.

    Any advice?

    Thank you!
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    I'll take a shot in the dark. This won't hurt anything if you try it.

    Perhaps your System User Interface preferences are corrupt. To find out and/or fix it, go to your User Folder: HD/Users/YourUserName/Library/Preferences

    Drag the file com.apple.systemuiserver.plist to the Desktop and Restart the computer. (Sorry, that's required to make a new file. Until you do this, the system will still be referring to the possibly corrupt file you're testing.)

    Now put it to sleep and see if it wakes up with full functionality. Let us know, should you decide to try this. If it doesn't help, you can put the old file back or just Trash it and use the newer one. Keeping it around is only a precaution in case (very low probability) the procedure makes things worse.
     
  3. LexieMSU08 thread starter macrumors newbie

    Joined:
    Apr 11, 2008
    Location:
    East Lansing
    #3
    Good News!

    The previous poster inspired me to not just check that one file's permissions, but to check out the entire disk, just to be sure. So I ran the disk utilities 'Verify Disk' and 'Verify Disk Permissions'. Disk verified no problem, but I had a bunch of permissions that were not right, so I repaired them, and viola! Fixed!

    Easy fix for something that was very strange..

    Thanks all!
     

Share This Page