PROGRAMS WON'T OPEN, "unexpectedly quit" error

rkw0704

macrumors newbie
Original poster
Nov 21, 2009
5
0
So itunes, ichat, safari, software updater, adobe products....all either bounce mindlessly and don't open or I get an error message saying: "The application quit unexpectedly" and won't open. I've even tried re-installing a few of these applications, and nothing has worked. All of this happened after my computer did some sort of software update..

I saw this thread and this guy spells out the same problems I was having:

http://forums.macrumors.com/showthread.php?t=745681

this is the error screen I get:
Process: iTunes [447]
Path: /Applications/iTunes.app/Contents/MacOS/iTunes
Identifier: com.apple.iTunes
Version: ??? (???)
Build Info: iTunes-9022501~2
Code Type: X86 (Native)
Parent Process: launchd [143]

Interval Since Last Report: 16 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 2

Date/Time: 2009-11-21 20:04:03.158 -0500
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: B7259C58-E7A6-4DE2-92A8-D05B2E2A2F3B

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Symbol not found: __ZNK3JSC6JSCell17getTruncatedInt32ERi
Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore



All say the same error message about the javascript...


HELP PLEASE :(
 

J the Ninja

macrumors 68000
Jul 14, 2008
1,824
0
That software update wouldn't have been Safari 4.0.4, would it? Because part or all of WebKit seems to be missing/corrupt. Using whatever computer you managed to post this with (maybe Firefox still works on the screwed up Mac?) go download the current version of Safari for Mac, run the installer, and reboot. See if that fixes the problem.

http://www.apple.com/safari/download/
 

rkw0704

macrumors newbie
Original poster
Nov 21, 2009
5
0
it worked!! thanks so much! screw apple and there damaging updates. now I have to re-upload all my music...minor detail though..

thanks so much for your help!
 

knutson

macrumors newbie
Dec 2, 2009
1
0
Programs still wont open, installer crash

The exact same thing happen to my computer when carrying out the update to Safari 4.0.4. Now Software Update, Safari, Mail wont open however in my case itunes still works fine, at least for now.
I erased Safari and tried to install again using firefox as suggested here, but the the Installer also crashes open opening so I am unable to install any new programs. I repaired disk permissions and repaired the disk and yet the same problems persists.
I am running tiger so its time for an upgrade to snow leopard but i am worried the problem will still persists if I migrate the files and programs from my current start up disc
Any suggestion of how to solve this issue would be greatly appreciated
 

patrick0brien

macrumors 68040
Oct 24, 2002
3,238
0
The West Loop
I would start with trashing the preferences files of Apps you feel are causing issues before going all the way to nuking the app itself. It may save a lot of time.
 

someguy

macrumors 68020
Dec 4, 2005
2,323
12
Still here.
The exact same thing happen to my computer when carrying out the update to Safari 4.0.4. Now Software Update, Safari, Mail wont open however in my case itunes still works fine, at least for now.
I erased Safari and tried to install again using firefox as suggested here, but the the Installer also crashes open opening so I am unable to install any new programs. I repaired disk permissions and repaired the disk and yet the same problems persists.
I am running tiger so its time for an upgrade to snow leopard but i am worried the problem will still persists if I migrate the files and programs from my current start up disc
Any suggestion of how to solve this issue would be greatly appreciated
You'll be much better off starting a new thread of your own for this issue. :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.