Prompts for old iTunes Store account

Discussion in 'iOS 9' started by jww062, Sep 9, 2015.

  1. jww062 macrumors member

    Joined:
    Dec 1, 2012
    #1
    The only issue I'm having with the 9 GM is it is constantly prompting me for an old password to iTunes Store.

    About a year ago, to consolidate emails, I logged into my Apple ID and changed the email address associated with it. Everything on my phone is configured with my newer email address, and has been for the past year. After restoring my phone backup, it prompts me for the password to my Apple ID with the old email address.

    I tried using the old and new passwords, but that doesn't work.
    I also tried adding this email as a secondary email on my current Apple ID, but that didn't work either.

    Just to be clear, it is only one account that I've ever had; I just changed the email associated with it last year, no problems until today.

    Any ideas?
     
  2. PedCrossing macrumors 6502

    PedCrossing

    Joined:
    Apr 3, 2012
    Location:
    The Loop
    #2
    Click cancel when it prompts again, some of the apps might disappear after the restore is done, just re-download the apps and you'll be fine. I had an email change a couple of years ago and got the same problem as yours, but I was on iOS 8.
     
  3. GregE240 macrumors newbie

    Joined:
    Sep 8, 2014
    #3
    Funnily enough, I had the exact same issue. I logged a call with Apple Support and spoke to a really helpful chap who basically asked me to rename by account back to what it was, sign out of everything (iCloud, Store, iMessage, Facetime), rename the account back then try again. It worked - after a fashion. I *think* the actual problem was an old app thats either not IOS9-friendly or actually does not exist anymore because after deleting it from both iTunes and my iPad, I'm not getting prompted anymore?

    I narrowed it down as I had one app left that just wasn't installing (it was FIFA13), and if I removed it, after a few minutes, I got the login prompt and it appeared but didn't download?

    Does that sound familiar?

    Cheers,
    Greg
     
  4. jww062 thread starter macrumors member

    Joined:
    Dec 1, 2012
    #4
    I was able to fix it by deleting the apps (which prompted me about 12 times a piece to enter the PW before finally deleting) and then reinstalling from the app store.

    The interesting thing is only one of the 6 apps that appeared to be causing the issue would have been downloaded on my old account. The others were downloaded since I switched (which I only know because I still have all the iTunes receipts in my gmail account and saw what email they were sent to).
     

Share This Page