Provisioning Error (sigh)

Discussion in 'iOS Programming' started by FetalSage, Apr 1, 2009.

  1. FetalSage macrumors regular

    Jul 5, 2007

    So I recently signed up for my own Developer Account after (and still connected) being an Academic iPhone Developer Account while still being in school. I removed the certificates and provisioning profiles (as best I could) from the academic profiles and installed my new certificates from my new developer account.

    When I try and build my application, for 2.2.1, I get the following error:



    I blurred out the rest of the key since I'm not sure if it might be a security thing or not. Everything checks out in the project properties in terms of selecting my developer account/certificate for the code signing.

    Any information would be appreciated!
  2. jfack24 macrumors newbie

    Apr 2, 2009
    Provisioning errors

    I was having similar problems, and what I found is that I had to select my target (in the left hand area), right-click it and choose "get info." It should bring up a similar window to what you see in the project settings Go into the build tab and check your settings for code signing there. I found that in these settings, xcode was still trying to use an old provisioning file even though I had made the appropriate changes to my project settings.

    Hope this helps, I know I was frustrated for a while trying to figure it out.

  3. caveman_uk Guest


    Feb 17, 2003
    Hitchin, Herts, UK
    Have you installed your new signing certs? If so you need to select them in xCode as it looks like it's trying to use the old ones. Try quitting xcode and restarting it a few times along the process as well as sometimes things don't seem to stick unless you do.
  4. Gottaa macrumors newbie

    Jan 28, 2009
    One very useful tip I found was to never install provision profiles via Xcode, but to just drag them into the correct directory, I tried for quite a while to get my distribution profile to work, and in the end deleting my profiles (which I'd tried before), but installing the new one's manually myself into the correct folder, and then a clean and restart of XCode later and all worked fine.

Share This Page